0

Mini POV4
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Mini POV4

by mbkhali on Mon Dec 25, 2017 1:35 am

I have soldered a mini POV4 kit i bought from here
I am using windows 10
With the USB adapter
It lit up when i turned the battery on
The second LED from the left and the second LED from the right do not light up the rest just flicker red
I think the 8-bit micro controller is defective
Attachments
unnamed (5).jpg
unnamed (5).jpg (598.15 KiB) Viewed 835 times
unnamed.jpg
unnamed.jpg (801.4 KiB) Viewed 835 times
unnamed (1).jpg
unnamed (1).jpg (600.09 KiB) Viewed 835 times

mbkhali
 
Posts: 37
Joined: Wed Dec 20, 2017 1:54 am

Re: Mini POV4

by adafruit_support_carter on Thu Dec 28, 2017 12:55 pm

Some of your solder connections look like they could be under or cold soldered. Take a look at this:
https://learn.adafruit.com/adafruit-gui ... n-problems
and then try reflowing any connections that look like they might not be making good electrical contact.

adafruit_support_carter
 
Posts: 11090
Joined: Tue Nov 29, 2016 2:45 pm

Re: Mini POV4

by mbkhali on Thu Dec 28, 2017 3:54 pm

I have already tried that and resoldered them but it’s the same output. When I push down really hard on the micro controller all the lights light up but just red

mbkhali
 
Posts: 37
Joined: Wed Dec 20, 2017 1:54 am

Re: Mini POV4

by adafruit_support_carter on Thu Dec 28, 2017 8:39 pm

That really sounds like some sort of electrical connection problem. By pressing down you're somehow forcing the connection closed. But there could also be other connection issues that are not being solved by the pressing down. Are the photos you posted of the reworked soldering?

adafruit_support_carter
 
Posts: 11090
Joined: Tue Nov 29, 2016 2:45 pm

Re: Mini POV4

by Mkhalil2 on Thu Dec 28, 2017 10:15 pm

No that was from the first time, the second time I resoldered all the components that looked like they needed resoldering

Mkhalil2
 
Posts: 17
Joined: Thu May 11, 2017 10:58 pm

Re: Mini POV4

by adafruit_support_carter on Thu Dec 28, 2017 10:58 pm

Post photos of the new solder job.

Does it show up at all when you plug it in via a USB cable to your computer? As described here for uploading new images:
https://learn.adafruit.com/minipov4-diy ... oad-images

adafruit_support_carter
 
Posts: 11090
Joined: Tue Nov 29, 2016 2:45 pm

Re: Mini POV4

by mbkhali on Fri Dec 29, 2017 12:18 am

I haven’t plugged it in yet because when I followed the steps it said it would light up the test image first which it didnt

mbkhali
 
Posts: 37
Joined: Wed Dec 20, 2017 1:54 am

Re: Mini POV4

by adafruit_support_carter on Fri Dec 29, 2017 12:25 pm

Yep. It should. From the guide:
Wait three seconds for the MiniPOV to 'boot' and you'll see the red, green and blue LEDs light up in order. Then the LEDs will flicker white.

The LEDs are basic RGB LEDs, with each color (red, green, and blue) controlled by a separate signal. By seeing only red, it indicates the possibility of a signal issue with the other two colors. There are several solder points that could cause this. If you post a second photo of the current solder job I can try and see if any of those specific points look like they might still have an issue.

The idea with plugging it in with a USB cable is just to provide another check.

adafruit_support_carter
 
Posts: 11090
Joined: Tue Nov 29, 2016 2:45 pm

Re: Mini POV4

by Mkhalil2 on Sat Dec 30, 2017 10:58 pm

Here is my updated solder now only one LED does not flash and the rest flash red on a repeated loop
Attachments
unnamed.jpg
unnamed.jpg (851.6 KiB) Viewed 722 times

Mkhalil2
 
Posts: 17
Joined: Thu May 11, 2017 10:58 pm

Re: Mini POV4

by adafruit_support_carter on Wed Jan 03, 2018 12:32 pm

Hey, mbkhali, I'll check out your soldering when I get a chance to compare to the schematic. In the meantime, can you try plugging it in to your computer via a USB cable and see if it is recognized at all.

adafruit_support_carter
 
Posts: 11090
Joined: Tue Nov 29, 2016 2:45 pm

Re: Mini POV4

by mbkhali on Wed Jan 03, 2018 7:07 pm

I get a notification that a device has been plugged in

mbkhali
 
Posts: 37
Joined: Wed Dec 20, 2017 1:54 am

Re: Mini POV4

by adafruit_support_carter on Thu Jan 04, 2018 9:39 am

Cool. It sounds like the chip is working and the USB connections are good. Give me a bit to take a look at your last photo and check it against the schematics and Ill get back to you.

adafruit_support_carter
 
Posts: 11090
Joined: Tue Nov 29, 2016 2:45 pm

Re: Mini POV4

by Mkhalil2 on Thu Jan 04, 2018 6:14 pm

yes but it says usb device not recognized

Mkhalil2
 
Posts: 17
Joined: Thu May 11, 2017 10:58 pm

Re: Mini POV4

by adafruit2 on Mon Jan 08, 2018 8:05 pm

hmm - i see a ton of shorted pins there, from solder being dragged
are you using rosin-core electronics solder? what iron are you using?

adafruit2
Site Admin
 
Posts: 18327
Joined: Fri Mar 11, 2005 7:36 pm

Re: Mini POV4

by Mkhalil2 on Mon Jan 08, 2018 8:28 pm

I’m using Rosin Core solder

Mkhalil2
 
Posts: 17
Joined: Thu May 11, 2017 10:58 pm

Please be positive and constructive with your questions and comments.