0

Error Downloading To The Mini POV 4 (OSX)
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Error Downloading To The Mini POV 4 (OSX)

by codyv on Wed Feb 24, 2016 2:15 pm

Helo, I'm not sure that my computer is communicating properly with my MINI POV 4. I have assembled the piece, and when I connect via usb and attempt to download, i get this error message. I have tried Processing 2.03, 2.11, & 3 with no luck. Can you help me figure out the problem?

done!
open: invalid option -- c
Usage: open [-e] [-t] [-f] [-W] [-R] [-n] [-g] [-h] [-b <bundle identifier>] [-a <application>] [filenames] [--args arguments]
Help: Open opens files from a shell.
By default, opens each file using the default application for that file.
If the file is in the form of a URL, the file will be opened as a URL.
Options:
-a Opens with the specified application.
-b Opens with the specified application bundle identifier.
-e Opens with TextEdit.
-t Opens with default text editor.
-f Reads input from standard input and opens with TextEdit.
-F --fresh Launches the app fresh, that is, without restoring windows. Saved persistent state is lost, excluding Untitled documents.
-R, --reveal Selects in the Finder instead of opening.
-W, --wait-apps Blocks until the used applications are closed (even if they were already running).
--args All remaining arguments are passed in argv to the application's main() function instead of opened.
-n, --new Open a new instance of the application even if one is already running.
-j, --hide Launches the app hidden.
-g, --background Does not bring the application to the foreground.
-h, --header Searches header file locations for headers matching the given filenames, and opens them.

temp.bin deleted

codyv
 
Posts: 1
Joined: Sat Feb 13, 2016 11:23 pm

Re: Error Downloading To The Mini POV 4 (OSX)

by adafruit2 on Sat Feb 27, 2016 7:23 pm

can you post a screenshot of when this happens?

adafruit2
Site Admin
 
Posts: 18327
Joined: Fri Mar 11, 2005 7:36 pm

Re: Error Downloading To The Mini POV 4 (OSX)

by cycliste737 on Thu Aug 18, 2016 8:31 pm

I am having a similar issue. No computers or operating systems that I attempt to use to load the code onto the POV work. It is flashing the default code just fine, and when a live USB cable is plugged into it, the LEDs flash appropriately for loading code. I have tried this on various machines with OSX El Capitan, Snow Leopard (too old for the version of Processing necessary), Yosemite, Mavericks and also on a Windows machine with the appropriate drivers installed. It's always an avrdude issue, and I've tried reinstalling avrdude locally as well as an updated version in the folder that the Processing window is calling it from. It says "Cannnot Connect to USBtiny device" with an error code. I am happy to post a screen shot of all errors as soon as my friend gives it back (he was trying it on one of his Windows machines with a different USB cable as well to verify this).

Curiously, none of these systems seem to recognize that the device is plugged in, meaning that in all of them it does not show up in the system report as a connected USB device of any sort. I cannot remember from programming other things like Trinkets if they show up either.

Please help! I am trying to get this sorted for an upcoming grant project, and if I'm able to get these bugs worked out may order between 10-20 of these devices for use teaching kids about persistence of vision.

Cheers,
~Nick Wethington

cycliste737
 
Posts: 3
Joined: Sun Mar 08, 2015 11:55 am

Re: Error Downloading To The Mini POV 4 (OSX)

by adafruit2 on Thu Aug 18, 2016 9:20 pm

check your soldering! you should see the device in dmesg or Usbprober (mac) or device manager (linux)

adafruit2
Site Admin
 
Posts: 18327
Joined: Fri Mar 11, 2005 7:36 pm

Re: Error Downloading To The Mini POV 4 (OSX)

by cycliste737 on Fri Aug 19, 2016 1:07 am

Is there a specific place I should check for this? The USB jack perhaps? Or another point on the board?

cycliste737
 
Posts: 3
Joined: Sun Mar 08, 2015 11:55 am

Re: Error Downloading To The Mini POV 4 (OSX)

by adafruit2 on Fri Aug 19, 2016 11:57 am

all around! post clear 800x600 photos if you have them

adafruit2
Site Admin
 
Posts: 18327
Joined: Fri Mar 11, 2005 7:36 pm

Re: Error Downloading To The Mini POV 4 (OSX)

by cycliste737 on Sat Aug 20, 2016 5:17 pm

I double-checked all of the solder points with my magnifying loupe, and ran a trace scraper between any that even looked close. Still the same. Curiously, I attached it to a different windows computer - as the LEDs blink on the POV, it flashes as a USB device on the computer momentarily, then disconnects, then reconnects, then disconnects ad infinitum. This is after installing the Adafruit drivers on the computer and rebooting. Here's a question: what should the LEDs be doing if it is properly entering the bootloader when connected via USB? They flash green, red, blue down the line, wait about 3 seconds, then do that again until the USB cable is disconnected. Other documentation I've come across indicates they should just blip green, so maybe there's something going on with the bootloader?

I did try this through a USB 2.0 hub that makes my Trinkets work just fine before scraping the traces, I will try again when I get home after making this modification to see if there is any difference.

cycliste737
 
Posts: 3
Joined: Sun Mar 08, 2015 11:55 am

Re: Error Downloading To The Mini POV 4 (OSX)

by adafruit2 on Sat Aug 20, 2016 8:53 pm

can't recall the bootup sequence but if its connecint/disconnecing a lot it sounds like a power/soldering issue for sure

adafruit2
Site Admin
 
Posts: 18327
Joined: Fri Mar 11, 2005 7:36 pm

Re: Error Downloading To The Mini POV 4 (OSX)

by onespeedonly on Fri Sep 23, 2016 7:37 am

codyv wrote:Helo, I'm not sure that my computer is communicating properly with my MINI POV 4. I have assembled the piece, and when I connect via usb and attempt to download, i get this error message. I have tried Processing 2.03, 2.11, & 3 with no luck. Can you help me figure out the problem?

done!
open: invalid option -- c
Usage: open [-e] [-t] [-f] [-W] [-R] [-n] [-g] [-h] [-b <bundle identifier>] [-a <application>] [filenames] [--args arguments]
Help: Open opens files from a shell.
By default, opens each file using the default application for that file.
If the file is in the form of a URL, the file will be opened as a URL.
Options:
-a Opens with the specified application.
-b Opens with the specified application bundle identifier.
-e Opens with TextEdit.
-t Opens with default text editor.
-f Reads input from standard input and opens with TextEdit.
-F --fresh Launches the app fresh, that is, without restoring windows. Saved persistent state is lost, excluding Untitled documents.
-R, --reveal Selects in the Finder instead of opening.
-W, --wait-apps Blocks until the used applications are closed (even if they were already running).
--args All remaining arguments are passed in argv to the application's main() function instead of opened.
-n, --new Open a new instance of the application even if one is already running.
-j, --hide Launches the app hidden.
-g, --background Does not bring the application to the foreground.
-h, --header Searches header file locations for headers matching the given filenames, and opens them.

temp.bin deleted


codyv, did you ever get a resolution to your problem, quoted above. I get the same error word for word when I attempt to load a new image.

To Adafruit support, I will post a screen shot and other details in a bit (not at my computer at the moment).

Regards,

Dan

onespeedonly
 
Posts: 11
Joined: Sun Jul 24, 2016 10:14 pm

Please be positive and constructive with your questions and comments.