📬❄️📦Adafruit Holiday Shipping Deadlines 2019: Attention all domestic customers! Please place UPS Ground and USPS First Class & Priority orders by 11am ET Monday December 9, 2019 📬❄️📦 Attention all international customers! Please place all UPS WORLDWIDE EXPRESS; SAVER, and DHL EXPRESS WORLDWIDE orders by 11am ET Monday December 9, 2019 📬❄️📦
0

SOLVED: Problems with IC12 and Filter Warble
Moderators: altitude, adafruit_support_bill, adafruit, phono, hamburgers

Please be positive and constructive with your questions and comments.

SOLVED: Problems with IC12 and Filter Warble

by substyler on Sun Mar 15, 2009 2:56 pm

hi folks

I have problems with filter warble on a x0xb0x I've build today. the warbling is only there when IC12 is in the socket, after pulling the 4066 the warbling sound is gone. I'v checked two other 4066, but the warbling still exist and I don't know why the warble is there.
have checked the whole area around IC12 and everything's looking fine.

I read this on IC12 when x0x is not playing :

Pin 1 = 0,03v
Pin 2 = 0v
Pin 3 = 0,02v
Pin 4 = 0,2v
Pin 5 = 0,02v
Pin 6 = 0,05v
Pin 7 = 0v
Pin 8 = 2,82v
Pin 9 = 2,85v
Pin 10 = 2,85v
Pin 11 = 2,85v
Pin 12 = 9,38v
Pin 13 = 0,02v
Pin 14 = 10,35v

I read this on IC12 when x0x is playing (cutoff and resonance is 70%) :

Pin 1 = 3,16v - 8,04v
Pin 2 = 0,9v - 3,65v
Pin 3 = 1,91v - 6,38v
Pin 4 = 1,24v - 1,45v
Pin 5 = 0,9v - 10,35v
Pin 6 = 0,06v - 10,4v
Pin 7 = 0v
Pin 8 = 2,16v - 2,84v
Pin 9 = 2,23v - 3,12v
Pin 10 = 1,89v - 3,4v
Pin 11 = 1,46v - 4v
Pin 12 = 0,5v - 10,4v
Pin 13 = 5,2v - 10,7v
Pin 14 = 10,5v - 11,82v

IC23 on the power supply is getting hot when the sound is warbling. any ideas ?

thnx in advance
SubStyler

Edit: when I pull out only Pin7 on IC12 the warble stops ?
Last edited by substyler on Sun Mar 22, 2009 9:15 am, edited 1 time in total.
electronics consists to 80% of superstition and to 20% of fairy tales • DIY or die!

substyler
 
Posts: 428
Joined: Tue Dec 02, 2008 6:29 pm
Location: Göttingen, Germany

Re: Problems with IC12 and Filter Warble

by guest on Mon Mar 16, 2009 2:54 pm

is ic23 getting hot when you dont have ic12 in
perhaps there is a short on the ic12 socket someplace
and it is drawing a lot of power from the powersupply
making the voltage droop and the sound warble

are there any accents or slides
in the voltage numbers youve given below
does it warble with some combination
of accents or slides either on or off

is ic12 socketed
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 5:35 am

Re: Problems with IC12 and Filter Warble

by substyler on Mon Mar 16, 2009 4:02 pm

hi guest,

thanks for reply. I don't know what's up.. building up 8 x0xen and now this :?

the warble is only there, when IC12 is in the socket and at this time IC23 is getting (very) hot. if I pull IC12 the warble is gone and IC23 stay cool.
the warble is there with or without any slides or accents.

do you know what voltages should be at the pins of IC21 and IC22 ?

cheers
SubStyler
electronics consists to 80% of superstition and to 20% of fairy tales • DIY or die!

substyler
 
Posts: 428
Joined: Tue Dec 02, 2008 6:29 pm
Location: Göttingen, Germany

Re: Problems with IC12 and Filter Warble

by guest on Mon Mar 16, 2009 4:21 pm

set the x0x in keyboard mode
and turn off all accents and slides
and then press the middle c key
and then take the voltages on ic12

it sounds like there is a short someplace
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 5:35 am

Re: Problems with IC12 and Filter Warble

by substyler on Wed Mar 18, 2009 8:42 am

thnx guest, I'll check that later.
electronics consists to 80% of superstition and to 20% of fairy tales • DIY or die!

substyler
 
Posts: 428
Joined: Tue Dec 02, 2008 6:29 pm
Location: Göttingen, Germany

Re: Problems with IC12 and Filter Warble

by substyler on Wed Mar 18, 2009 6:33 pm

hi guest,
have not checked the voltages as you said, but I found that sound is normal when the x0x is in random mode. :?
when I turn back to play or edit mode and there's a accented note or a slide the warble comes back.
maybe a bad dual pot ?

cheers
SubStyler
Last edited by substyler on Wed Mar 18, 2009 6:46 pm, edited 1 time in total.
electronics consists to 80% of superstition and to 20% of fairy tales • DIY or die!

substyler
 
Posts: 428
Joined: Tue Dec 02, 2008 6:29 pm
Location: Göttingen, Germany

Re: Problems with IC12 and Filter Warble

by guest on Wed Mar 18, 2009 6:45 pm

that seems odd
perhaps the accents and slides dont get turned on
that often in random mode

when you take those voltages
if you could take a set with only accent on
and with only slide on
that would help as well
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 5:35 am

Re: Problems with IC12 and Filter Warble

by substyler on Wed Mar 18, 2009 8:06 pm

guest,

I measured the voltages on IC12
first without accents and slides:
Pin 1 = 6,6v
Pin 2 = 0v
Pin 3 = 5,55v
Pin 4 = 1,41v
Pin 5 = 0,02v
Pin 6 = 0,04v
Pin 7 = 0v
Pin 8 = 1,8v - 3,15v
Pin 9 = 1,8v - 3,5v
Pin 10 = 1,8v - 3,4v
Pin 11 = 0v
Pin 12 = 9,38v
Pin 13 = 0,02v
Pin 14 = 10,35v

then with some accented notes (accent pot turned all the way up)
Pin 1 = 5,3v - 7,5v
Pin 2 = 0v - 3,3v
Pin 3 = 2,7v - 6,3v
Pin 4 = 1,41v
Pin 5 = 0v - 7,6v
Pin 6 = 0,04v
Pin 7 = 0v
Pin 8 = 1,6v - 3,5v
Pin 9 = 1,5v - 3,5v
Pin 10 = 1,8v - 3,5v
Pin 11 = 1,8v - 3,5v
Pin 12 = 9,5v - 10,8v
Pin 13 = 0,2v - 8v
Pin 14 = 10,35v - 11,91v

and with only some slides (resonance 100 %)
Pin 1 = 7,7v - 9,5v
Pin 2 = 0v
Pin 3 = 0v
Pin 4 = 1,31v
Pin 5 = 0,02v
Pin 6 = 0,5v - 10,4v
Pin 7 = 0v
Pin 8 = 1,6v - 3,5v
Pin 9 = 1,5v - 3,5v
Pin 10 = 1,7v - 3,4v
Pin 11 = 1,6v - 3,5v
Pin 12 = 0,1v - 10,8v
Pin 13 = 0,02v
Pin 14 = 10,8v - 11,91v

hope that you can see anything :)
thnx in advance !

SubStyler
electronics consists to 80% of superstition and to 20% of fairy tales • DIY or die!

substyler
 
Posts: 428
Joined: Tue Dec 02, 2008 6:29 pm
Location: Göttingen, Germany

Re: Problems with IC12 and Filter Warble

by guest on Wed Mar 18, 2009 9:36 pm

i cant find anything wrong with those voltages
some of them are a bit off
but im not sure whats causing it

the next step is to check manually for shorts
remove the 4066
and measure the resistance to both ground and 12v
from each pin
and then measure the resistance from each pin
to both of its neighbors
except for a few of the pins
they should all be in the kilohm range or higher

also double check q29 q30 and q35
and all of the resistors connected to them
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 5:35 am

Re: Problems with IC12 and Filter Warble

by substyler on Thu Mar 19, 2009 7:40 pm

hi guest,

I'm going nuts :cry:
have double and triple checked every damn thing on that x0x, but warble still persists.
the only solution to kill the warble is to turn TM6 down to 5,2V or so... but, I think thats not the correct solution :)
have tried three different powersupplys (and all work fine) but it does not help.

cheers
SubStyler
electronics consists to 80% of superstition and to 20% of fairy tales • DIY or die!

substyler
 
Posts: 428
Joined: Tue Dec 02, 2008 6:29 pm
Location: Göttingen, Germany

Re: Problems with IC12 and Filter Warble

by guest on Thu Mar 19, 2009 9:39 pm

what is the voltage on c8
in a nonwarble state

double check r1 to make sure its 100ohms
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 5:35 am

Re: Problems with IC12 and Filter Warble

by substyler on Fri Mar 20, 2009 8:06 am

in a nonwarble state the voltage across C8 is around 27v
with accent or slides the voltage goes down to 23,6 - 23,8v
r1 is 100ohm and the resistor seems to be ok.
electronics consists to 80% of superstition and to 20% of fairy tales • DIY or die!

substyler
 
Posts: 428
Joined: Tue Dec 02, 2008 6:29 pm
Location: Göttingen, Germany

Re: Problems with IC12 and Filter Warble

by guest on Fri Mar 20, 2009 3:13 pm

is it possible that all of the 4066s you tried were bad
were they all from the same source

if you have the chip out
and you turn on accents and slides
does it still warble

it is strange that it happens with either accent or slides or both
so its not just a short in one part of the circuit
its more like a short between the two parts of the circuits

something you can try is to activate accents and slides manually
and see what happens
if you remove the chip and use jumpers to short out the pins
you can simulate the 4066 switching
this will eliminate the chip as being bad
if it still warbles when you do the chips task for it
normal mode is pins 10 and 11 shorted and everything else open
slides are pins 8 and 9 shorted and everything else open
accents are pins 1 and 2 shorted and pins 3 and 4 shorted

you can set it up in normal mode
and then start putting in jumpers until it warbles
and if none of those make it warble
all of the chips youve tested are probably bad

do you have ic12 socketed
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 5:35 am

Re: Problems with IC12 and Filter Warble

by substyler on Fri Mar 20, 2009 5:18 pm

hi guest,

is it possible that all of the 4066s you tried were bad
were they all from the same source

no, I have tried 4066 from three different supplyers and different manufacturers.
I check those ICs in another x0x I have and they're working.

if you have the chip out
and you turn on accents and slides
does it still warble

no, when I pull the 4066 the warble is gone. (and accentet notes of course too)
I have all ICs socketed becuse I'm a bit nervous about soldering ICs :)
in this special case I soldered the IC socket out and solder in the 4066 directly. but the problem still persists.
as I told, when I turn the 5,333v on TM6 down to around 5,2v the warble is gone.
that is strange.

it is strange that it happens with either accent or slides or both
so its not just a short in one part of the circuit
its more like a short between the two parts of the circuits

yeah, without any accent or slides in the notes, the x0x is playing fine.
but if I give accent to any note, the warble is back and the whole sound is dropping.


cheers
SubStyler

btw: thank you very much for all the hints !
electronics consists to 80% of superstition and to 20% of fairy tales • DIY or die!

substyler
 
Posts: 428
Joined: Tue Dec 02, 2008 6:29 pm
Location: Göttingen, Germany

Re: Problems with IC12 and Filter Warble : SOLVED !

by substyler on Sun Mar 22, 2009 9:14 am

hi guest,

first I have to say: YOU RULE ! 8)
after you told me to check the socket for IC12 with jumpers I found that a whole tube of 4066's faulty !
it's still unbelievable ! more than 20 hours of madness for troubleshooting.
I opened another tube, put the 4066 in... and: hooray ! it works :-)
thank you so very much !

cheers
SubStyler

PS: please PM me where I have to send the beer :mrgreen:
electronics consists to 80% of superstition and to 20% of fairy tales • DIY or die!

substyler
 
Posts: 428
Joined: Tue Dec 02, 2008 6:29 pm
Location: Göttingen, Germany

Please be positive and constructive with your questions and comments.