0

Note E (S19) does not release
Moderators: altitude, adafruit_support_bill, adafruit, phono, hamburgers

Please be positive and constructive with your questions and comments.

Note E (S19) does not release

by jorrit on Mon Mar 05, 2018 8:03 am

Hello there, please help me troubleshooting an error.

When in keyboard mode, switch 19 does not release after unpressed. The according LED 32 keeps burning and note E keeps playing (slowly releasing). After 10 seconds or so, the note is stopped and the LED stops burning. Secondly, when switch 19 is pressed once and released after circa 10 seconds, it gets activated as well when neighbour switches 18 or 20 are physically pressed. I demonstrate both behaviours in this video: https://www.youtube.com/watch?v=B9-FS3PB9R0

I replaced switch 19 but this did not solve the problem. The x0xb0x is bought second hand like this and comes originally from x0xsh0p.de. I succesfully assembled two x0xb0xes earlier, but my general electro theory knowledge is low.

Please help me troubleshooting the error, for example by suggesting which components to test or replace. Thanks in advance.

jorrit
 
Posts: 5
Joined: Sat Jun 03, 2017 2:04 pm

Re: Note E (S19) does not release

by antto on Mon Mar 05, 2018 7:35 pm

things i would check are:
- the +5V voltage while you're pressing (holding) the button that acts weird - does the 5V supply rail drop down? that could indicate a short circuit somewhere

- check neighbour input pins on the PISO shift registers (the 74xx165 chips) for shorts
- maybe also check neighbour output pins on the SIPOs (the 74xx595 chips) for shorts

antto
 
Posts: 1617
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Please be positive and constructive with your questions and comments.