๐Ÿ“ฃ๐Ÿ“ช ๐Ÿšš Adafruit will not be shipping USPS orders Monday January 20, 2020 ๐Ÿ—“. Expedited USPS orders placed after 11am ET ๐Ÿ•š Friday January 17 will go out Tuesday January 21 ๐Ÿ“ฃ๐Ÿ“ช๐Ÿšš
0

No Sync/Can't Update Firmware
Moderators: altitude, adafruit_support_bill, adafruit, phono, hamburgers

Please be positive and constructive with your questions and comments.

No Sync/Can't Update Firmware

by jaeysin on Tue Jul 09, 2019 3:47 pm

Hello!

I have a second hand (nonadafruit) xoxbox that is having some issues. It doesn't seem to be able to sync midi or din, and I haven't been able to update or change the firmware either. I followed the instructions to use c0nb0x, I installed the ftdi-vcp drivers for OSX. Booted up the xoxbox in bootload mode, but I never see a recognized device show up in the OSX System Report, or in c0nb0x. Should any lights be on the device when in bootload mode? Sometimes I get all lights, sometimes I get none.

Besides the sync issue, the xoxbox makes sounds and the sequencer runs.

any ideas? Next step is to crack it open and see what's happening inside, but I wondered if there was anything else I should try.

thanks!
Jason

jaeysin
 
Posts: 2
Joined: Tue Jul 09, 2019 3:39 pm

Re: No Sync/Can't Update Firmware

by antto on Sun Jul 14, 2019 7:29 am

as long as you have a working firmware: test if your bootloader even works
- set it to BOOTLOAD mode
- power off
- power on (some or none or all LEDs might be on/off, ignore this)
- switch to another mode, like pattern play or keyboard mode
- if the thing responds - then it's running the main firmware, which means the bootloader didn't start
- if it doesn't appear to change - perhaps the bootloader is there and works

the bootloader doesn't touch the LEDs, so they don't get cleared and they start in a quasi-random state

antto
 
Posts: 1633
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: No Sync/Can't Update Firmware

by jaeysin on Mon Jul 15, 2019 11:53 am

Hi Antto,

I ran thru those steps, it does go into bootloader mode, but I can't get the software to recognize it. I opened it up and it's pretty poorly assembled with lots of bad solder points. I'm going to start by touching up all the connections and testing it again. :/

thanks for your insights!
J

jaeysin
 
Posts: 2
Joined: Tue Jul 09, 2019 3:39 pm

Please be positive and constructive with your questions and comments.