0

Bootloading?
Moderators: altitude, adafruit_support_bill, adafruit, hamburgers, phono

Please be positive and constructive with your questions and comments.

Bootloading?

by Frebrik on Mon Jun 06, 2005 2:27 pm

Hi,

I finished my #20 a couple of days ago and it has been working fine since then until...

I accidentally unplugged power while playing it in MIDI-mode, when I plugged power back in again it refused to boot. All I get is some random LED's lit up.

I guess I need to upload the firmware again, but I can not find it anywhere. Is it not available for download yet?

thanks

/F
Frebrik
 

by adafruit on Mon Jun 06, 2005 3:40 pm

hmm. that sounds bad. you can download the latest firmware from http://sourceforge.net/projects/x0xb0x

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by adafruit on Mon Jun 06, 2005 3:49 pm

this may be a brown-out problem. problem is, its difficult to debug this sort of issue because its random. i'll look into it and post an analysis/solution.

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by Frebrik on Tue Jun 07, 2005 3:31 am

The only guess I have to what happened is that the immense MIDI stream fed to the x0xb0x both when it lost power and when it powered up again could have something to do with it. I will try do upload the firmware tonight when I get back home from work.

You should have made it battery powered... ;-)

thanks!

/F
Frebrik
 

by BijouBittersolie on Tue Jun 07, 2005 1:11 pm

YOU should have made it battery powered :)
BijouBittersolie
 
Posts: 28
Joined: Wed Apr 06, 2005 10:33 am

by Frebrik on Tue Jun 07, 2005 5:26 pm

BijouBittersolie wrote:YOU should have made it battery powered :)


Hehe, I am actually thinking of it, but fitting 8 A-cells is out of the question...
But I have started on installing a power switch.

Uploading the firmware worked*, it is rocking again. Maybe the stream of MTC from the Alesis Micron made the x0xb0x puke? I don't know, I will try to make it happen again.

*It sucks that Java1.5 isn't available for MacOSX < 10.4. I had to dig out an old PeeCee running Win98, and that really sucked! Make room for Java, find the right comm-stuff, after an hour realise that it is the install instructions for jre1.2 that is valid when you have 1.5... crappeticrap!

thanks all :)

/F
Frebrik
 

Please be positive and constructive with your questions and comments.


cron