0

Dodgy USB Jack (Pre-Assembled)
Moderators: altitude, adafruit_support_bill, adafruit, hamburgers, phono

Please be positive and constructive with your questions and comments.

Dodgy USB Jack (Pre-Assembled)

by BijouBittersolie on Sat Jun 18, 2005 10:04 am

I've found that my USB jack is quite tempermental. I had to wiggle the USB cable a bit in order to get WinXP to recognize the COM port. The drivers installed fine, but now with my Device Manager open I see the new COM port disappearing and re-appearing with even minute changes in the USB cable or IO board position. Is this something that will stabilize once the IO board is mounted in the case or should I pick up a new USB jack right now and be done with it?

BYE!
BijouBittersolie
 
Posts: 28
Joined: Wed Apr 06, 2005 10:33 am

by adafruit on Sat Jun 18, 2005 12:54 pm

one thing to verify is that it may be your cable (those things cost $2 for a reason!)

another thing you can do is 'reflow' the USB connector (basically, reheat the USB connector pins, maybe put a tad more solder on the connectors)
also check that the two large 'mounting pins' have lots of solder on them, and reflow those too.

also look to see if anything is shorting in the usb section, are two resistors touching, etc? that can also cause it to flake.

let me know if this helps

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by BijouBittersolie on Sat Jun 18, 2005 11:49 pm

OK thanks Lady, looked like a flux bubble on one of the 4 USB pins. Works fine now.

BYE!
BijouBittersolie
 
Posts: 28
Joined: Wed Apr 06, 2005 10:33 am

Please be positive and constructive with your questions and comments.