0

How does the I/O fit in?
Moderators: altitude, adafruit_support_bill, adafruit, phono, hamburgers

Please be positive and constructive with your questions and comments.

How does the I/O fit in?

by Pish on Mon Apr 15, 2013 6:43 pm

I'm building the VCO.

Built a little kit from maplin as the power supply.
http://www.vellemanusa.com/products/vie ... &id=350481

Put a battery on it. Connected up.
Power supply on.
TM4/5 Centred.
Checked the DC bias using my meter. CORRECT.

It performs like it should like it says in the instructions, I can hear buzzing that changes pitch
But using the sound card scope and the suggested soldered clips it doesnt look very saw like.

Anything I should check or carry on?

Image
Last edited by Pish on Wed Jul 17, 2013 6:02 pm, edited 2 times in total.
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by antto on Mon Apr 15, 2013 7:02 pm

i'd say ignore this, either the scope or soundcard is acting weird
the VCO is biased so it might be clipping in your soundcard inputs

you could try running the probe signal thru a 1Meg pot and adjust it while looking at the scope
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1632
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: Testing VCO with soundcard scope. Doesnt look the same.

by Pish on Mon Apr 15, 2013 7:05 pm

Image

Image

Using 7805 tab for both power and scope grounds
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by Pish on Mon Apr 15, 2013 7:07 pm

Instead of the 10k pot on the probes?
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by MMM on Tue Apr 16, 2013 3:19 am

The scope pics don't even look remotely like the real waveform.

First of all the waveform looks like it has both positive and negative symmetrical components; this shouldn't happen with the sawtooth at all.
In addition it appears as if it has just about 200mV peak to peak; this would be way too small.

I don't know if this is the result of the soundcard scope acting up.
MMM
 
Posts: 486
Joined: Tue Apr 24, 2012 1:51 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by Pish on Tue Apr 16, 2013 2:43 pm

Any suggestions then?
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by antto on Tue Apr 16, 2013 3:49 pm

if it sounds fine - my suggestion is to continue forward with the build
you can check the signal again once you put the VCF together
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1632
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: Testing VCO with soundcard scope. Doesnt look the same.

by Pish on Tue Apr 16, 2013 5:31 pm

Is there anything I can test my soundcard scope against?
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by Pish on Tue Apr 16, 2013 7:09 pm

Is it worth making a little frequency generator kit to test it on?
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by antto on Wed Apr 17, 2013 2:28 pm

well, it's up to you
but IMO you can simply continue and checks things again when you build the VCF section
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)

antto
 
Posts: 1632
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: Testing VCO with soundcard scope. Doesnt look the same.

by Pish on Wed Apr 17, 2013 5:48 pm

Cheers mate.

Ill just make sure I keep logs as i go
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by Pish on Mon Apr 22, 2013 6:41 pm

Got a second hand, hand held Velleman HPS140. I'll give it a go tomorrow.
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by Pish on Tue Apr 23, 2013 8:32 am

Alot more like it!

Image
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by MMM on Wed Apr 24, 2013 1:45 am

Definitely!

Let us know how everything else turns out.
MMM
 
Posts: 486
Joined: Tue Apr 24, 2012 1:51 am

Re: Testing VCO with soundcard scope. Doesnt look the same.

by Pish on Wed Apr 24, 2013 1:17 pm

I was worrying I'd done something wrong but, Ive got the solder bug at the moment so I thought £40 for a £100 scope aint too bad.

Image

Built the VCF but broke the point off the probe D: !!!! Have to find/order one

Image
Pish
 
Posts: 85
Joined: Sun Jul 29, 2012 8:54 am

Please be positive and constructive with your questions and comments.