MarOS1.5.0 - Beta Version

Discuss mods, hacks, tweaks, etc.

Moderators: altitude, adafruit_support_bill, adafruit, hamburgers, phono

Please be positive and constructive with your questions and comments.
Locked
roxxx303
 
Posts: 93
Joined: Tue Nov 08, 2011 11:33 am

Re: MarOS1.4.1 - "Official" Version 1.4.1

Post by roxxx303 »

mario1089 wrote:Sorry for the loooong delay, I was so busy with many other projects, and I can't post it without a new documentation. Working on that right now.
Thank god you're still alive! :-)
We are very curious which features your next version will give to our beloved x0xb0x!

Please hurry up! ;-)

roxxx303
 
Posts: 93
Joined: Tue Nov 08, 2011 11:33 am

Re: MarOS1.4.1 - "Official" Version 1.4.1

Post by roxxx303 »

Hi Mario,

did you cooperate/shared the code for the new version with user "nordcore"?
He wrote a lot about code-optimisations he made, but I never saw a new version released by him!
Regards!

mario1089
 
Posts: 208
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS1.4.1 - "Official" Version 1.4.1

Post by mario1089 »

Yes nordcore rewrote a fair bit of the firmware, saving incredible amounts of bytes, while also improving timing issues and generally code quality.
Most of the bytes he saved I almost immediately reused:) He also ported some ideas from latest SokOS to MarOs.

Just a day or so until release..

roxxx303
 
Posts: 93
Joined: Tue Nov 08, 2011 11:33 am

Re: MarOS1.4.1 - "Official" Version 1.4.1

Post by roxxx303 »

Cool!

User avatar
manneokoko
 
Posts: 10
Joined: Tue Feb 16, 2016 1:58 am

Re: MarOS1.4.1 - "Official" Version 1.4.1

Post by manneokoko »

Bug report:

When changing from pattern edit, to pattern play, either midi sync or sync out. Sometimes the sequencer stops. The unit keeps on sending out midiclock, but the internal seq is stopped.

Very happy to see that MarOS is still alive !

User avatar
manneokoko
 
Posts: 10
Joined: Tue Feb 16, 2016 1:58 am

Re: MarOS1.4.1 - "Official" Version 1.4.1

Post by manneokoko »

A couple of more problems with the current OS:

If changing from edit to play mode, when randomize is activated (forgetting to exit random mode before going out of edit) - then the sequencer locks. It does not respond to niether midi stop message or pressing the run/stop button. I think it also looses midisync.

Same problem if changing from edit to play mode, while in process of saving (forgetting to press 2 times). If possible with some visual feedback while saving would be good.

I gotta say, the MarOS has really pumped new life into the x0xb0x. The randomizer is so amazing!

mario1089
 
Posts: 208
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS1.5.0 - Beta Version

Post by mario1089 »

see top post, new version 1.5.0 is there.

User avatar
54656f
 
Posts: 4
Joined: Sun Apr 27, 2014 11:13 am

Re: MarOS1.5.0 - Beta Version

Post by 54656f »

mario1089 wrote:see top post, new version 1.5.0 is there.
Woo-Hoo! Yippee!

Thank You Mario1089!

User avatar
manneokoko
 
Posts: 10
Joined: Tue Feb 16, 2016 1:58 am

Re: MarOS1.5.0 - Beta Version

Post by manneokoko »

Very very nice, many bugs fixed and improved features. Randomizer makes even more amazing patterns now!

I found one minor bug:
The "dirty flag" doesn't work. That is, the done LED does not light up when a pattern has been edited. Or maybe its just my Done LED that doesn't work.. Well, doesn't matter that much, save function is much improved since 1.4 and working fine.

mario1089
 
Posts: 208
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS1.5.0 - Beta Version

Post by mario1089 »

well mine does blink, once I ve changed a step.. can you check whether it depends on any specific way of editing, that it works or doesnt?

User avatar
manneokoko
 
Posts: 10
Joined: Tue Feb 16, 2016 1:58 am

Re: MarOS1.5.0 - Beta Version

Post by manneokoko »

I have checked the done LED, and it newer lifhts or blinks whatever edits I do. Maybe the LED is broken. Is it supposed to light up in any other command than the "dirty" flag?

User avatar
JuanTT
 
Posts: 8
Joined: Mon Jul 13, 2015 2:08 pm

Re: MarOS1.5.0 - Beta Version

Post by JuanTT »

GREAT!!! As soon as I arrive home I will test it. One thing I would love that you removed from the original Sokkos was the ability of switch pattern with Program Change, that's important for me because I'm using an Elektron Rytm and I could sync the patterns.

mario1089
 
Posts: 208
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS1.5.0 - Beta Version

Post by mario1089 »

DONE does light up for various reasons, if it doesnt do ever, its surely broken physically.

Program Change to Pattern Change seems a reasonable point to me, must say. I'll put it on a list of things to adress once more feedback is coming.

@ EVERYBODY:
The firmware was touched heavily. Please also confirm things are still WORKING!
MIDI Out? MIDI Beat Clock Out? DIN Sync IN? Din Sync OUT? All that little things about editing that are beyond my specific workflows? This and that?
I'll propably wait a bit more, and do one more version, not more:)

User avatar
JuanTT
 
Posts: 8
Joined: Mon Jul 13, 2015 2:08 pm

Re: MarOS1.5.0 - Beta Version

Post by JuanTT »

If you may do it, it would be really fantastic. I'd really love to sync it with the Elektron analog gear. I couldn't update yet, since I'm finishing a record with Sokkos 2 (it allows Program changes), and I don't want to risk to lose my work. However I will do as soon as I finish it!

User avatar
JuanTT
 
Posts: 8
Joined: Mon Jul 13, 2015 2:08 pm

Re: MarOS1.5.0 - Beta Version

Post by JuanTT »

Hello Mario,

Finally I'm testing the MarOS 1.5. It looks really nice, I only used it one hour, but I will experiment more this weekend.

There is a problem with the auto increment for step mode, it doesn't work while the pattern is running (I tried with the x0xb0x as standalone, not commanded with MIDI).
And I miss so hard the Program Change to switch pattern and do it compatible with my Analog Rytm - please ;)

Locked
Please be positive and constructive with your questions and comments.

Return to “x0xm0dz”