MIDIsense can no longer find my ADio Board
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

MIDIsense can no longer find my ADio Board

by Emma on Thu Apr 10, 2008 7:24 am

Hi - I hope you can help:

(I'm a complete novice and have never built a kit anything before. A by-product of this is that my technical vocabulary is non-existent, so please bear with me.)


My query sounds a lot like the one in this topic:
http://forums.ladyada.net/viewtopic.php ... +green+red
I had a lot of problems with connecting up the ADio board yesterday (see below), but when I turned it on this morning, it behaved just as Bunex describes in this post.

I think too have accidentally broken the microcontroller, and before reordering wanted to:
(1) check that the replacement I need to order is this one:
http://www.adafruit.com/index.php?main_ ... ucts_id=87

(2) run past you the problems I was experiencing yesterday:

[NB. This is my set up: Mac PowerPC G4 Powerbook 1.33GhZ, OS X 10.4.11; MIDISense ADio Board; Sharp GP2D12 Distance Measuring Sensor; M-Audio MIDISport Uno; MIDIsense v1.0c; MIDIMonitor 1.1.8.; 9V Duracell battery]

I managed to assemble and solder the board okay, hook up the sensor, everything. I installed the MIDI Monitor software that you suggested, and I could see that loads of MIDI information was flowing out of the sensor kit via the USB MIDI Interface. But the Midi Sense software itself wasn't working:

When I selected "Connect to MIDI", MIDIsense was able to find the kit, but all the options (e.g. 'Settings', 'Calibration') were greyed out, none of the drop-down menus were accessible, and none of the channel sliders reacted to the sensors. (Meanwhile, MIDI Monitor was registering loads of data from all the Analogue Inputs on the ADio board, even though only 1 sensor was attached.)

Eventually, I tried "Reset to factory settings". Then I was at least able to access the channels' drop down menus, but still there was no response to the presence of the sensor. Also, a sliver of the right hand edge of the programme interface window appeared on the far left of the window. No 'S' on 'Settings, etc.'. [Sorry, no photo: I had no idea that the software wouldn't be able to find the board this morning.]

Finally, I tried both verifying and upgrading the firmare. But when I tried to do either, I just keep getting an error message telling me that MIDI Sense has lost contact with the board.

At this point, I decided to call it a day. This morning, the software cannot find the board at all, and no MIDI information is registering in MIDIMonitor. When I turn on the power, the LED2 on the board flashes green, then red then off when I turn on the power.


I think that something fishy was definitely going on with the software, but I broke the microcontroller while trying to put it right.

Is the MIDIsense ADIO chip v1.2 the correct replacement part?
How can I avoid the problems I was experiencing yesterday?

With thanks and best wishes,

Posts: 1
Joined: Thu Apr 10, 2008 6:54 am
Location: London, UK

by soundlimit15 on Fri Apr 11, 2008 9:48 pm

I had a similar problem when first firing up the kit but it seemed only to be one of the midi leads although it was working ok on other gear.It iseems that your midi out from the kit is sending data to your mac but you may not be recieving via the adio midi in.I found two reasons for the continuous output of midi data from the kit,one is a setting in the midisense program and can be turned off,the other I found ports that were turned on but had no inputs had a slight jitter which sent out continuous midi data.Once something was connected to them or the unused ports were turned off all was ok.Hope this is of some help,Cheers,soundlimit
Posts: 8
Joined: Fri Mar 14, 2008 9:06 pm

by adafruit on Thu Apr 24, 2008 12:18 pm

if you tried to upload the firmware and failed it could have damaged the chip and made it not really not working. (this is why i put multiple warnings on the webpage...its REALLY not suggested)

you might just have to buy a replacement chip. you should also try using the latest software which is only available right now on windows. dunno if thats possible. i have to finish compiling it for Mac...

Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Please be positive and constructive with your questions and comments.