0

Charging problems
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Charging problems

by Ryint on Mon Jan 02, 2017 6:44 pm

This is my second mintyboost build but for some reason the charging logo on my devices appears but the batteries drain instead of charge. Tried with fresh batteries on a Huawei p9 and iPad mini with no luck. Checked and double checked the board and there's no cold joints or shorts.
Any suggestions would be great.
Thanks
Attachments
IMG_20170102_224303.jpg
Topside
IMG_20170102_224303.jpg (900.04 KiB) Viewed 860 times
IMG_20170102_223741.jpg
Bottomside
IMG_20170102_223741.jpg (880.84 KiB) Viewed 860 times

Ryint
 
Posts: 2
Joined: Mon Jan 02, 2017 6:27 pm

Re: Charging problems

by adafruit_support_bill on Tue Jan 03, 2017 6:53 am

Not sure about the charge current requirements of the Huawei, but I believe that the iPad Mini needs at least 1A and the MintyBoost is only capable of sustaining 500mA.

adafruit_support_bill
 
Posts: 70037
Joined: Sat Feb 07, 2009 10:11 am

Re: Charging problems

by Ryint on Mon Jan 09, 2017 12:48 pm

I've since tried it with some older devices that worked fine with my first build and still had no luck. Could it maybe be a USB spec thing?

Ryint
 
Posts: 2
Joined: Mon Jan 02, 2017 6:27 pm

Re: Charging problems

by adafruit_support_bill on Mon Jan 09, 2017 1:28 pm

Check to make sure that the output is steady and close to 5v. Also check the voltages on the two data pins.

adafruit_support_bill
 
Posts: 70037
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.