0

SpokePOV doesnt work
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

SpokePOV doesnt work

by thisisvlad on Sat Aug 29, 2015 8:25 pm

I bought 4 of these kits and none of them seem to work. clearly i did something wrong on all 4 of them :-/.

i have 2 yellow ones and 2 blue ones. when i put the batteries in, they go through the test sequence and each LED lights up in turn. i assembled the usbTiny and programmed each of them. that seemed to work because afterwards i was able to "Read from SpokePOV" and the image returned correctly. However, spinning my eheel does nothing. i only see the two test LEDs on and nothing else. also, my batteries exploded on one of the kits... i guess i was supposed to take the batteries out while programming it?

Here are photos of each side of the 4 kits: https://goo.gl/photos/Nnt4T4E4psEf9LrH9

any thoughts on what i messed up?

thanks!

thisisvlad
 
Posts: 2
Joined: Sat Aug 29, 2015 8:10 pm

Re: SpokePOV doesnt work

by adafruit_support_bill on Sun Aug 30, 2015 6:32 am

If you are able to program it and read the image back, then they are probably assembled correctly. It sounds like your problem is with the triggering circuit.

Make sure that the magnet is close enough to the Hall sensor.
Also make sure that the magnet is facing the right way. It will only work if the South pole of the magnet is facing the sensor.

adafruit_support_bill
 
Posts: 73497
Joined: Sat Feb 07, 2009 10:11 am

Re: SpokePOV doesnt work

by thisisvlad on Sun Aug 30, 2015 6:47 pm

awesome.. thanks so much for the advice!! :)

unfortunately, my bike is at my friend's house now, but i will get a chance to try this tomorrow night when i go there. this will be my last chance to try anything before i leave for burning man, so if i don't get it working then, it'll be $200+ down the drain plus a bunch of time wasted. any other tips on things i can try if the magnet thing doesn't do the trick?

thanks in advance for any additional thoughts!

thisisvlad
 
Posts: 2
Joined: Sat Aug 29, 2015 8:10 pm

Re: SpokePOV doesnt work

by adafruit_support_bill on Mon Aug 31, 2015 7:56 am

You can also try manually triggering it. If you short the sensor input (pin 7 on the ATTiny processor) to ground briefly a few times, you should see the leds sequence through the image.

adafruit_support_bill
 
Posts: 73497
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.