0

metro m0 express: arduino IDE upload auto launches file mana
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

metro m0 express: arduino IDE upload auto launches file mana

by Christopher123 on Mon Aug 07, 2017 7:14 pm

Every time the Arduino IDE (1.8.3) uploads my code to the Metro M0 Express the OS (linux mint 17.3) auto launches the file manager (Nemo) and displays this warning message " 'METROBOOT' could not be found. Perhaps it has recently been deleted."

Is this a bug with arduino IDE or a feature?

How can I suppress these actions (the auto launch and the warning message)?

Thanks for you help,
Christopher

Christopher123
 
Posts: 2
Joined: Mon Aug 07, 2017 6:56 pm

Re: metro m0 express: arduino IDE upload auto launches file

by adafruit_support_mike on Tue Aug 08, 2017 3:38 am

It's more like a misfeature.. an unwanted consequence of features that are otherwise useful.

The microcontroller handles USB internally, so it has to shut down the USB connection that makes the board look like a removeable drive before it can launch the bootloader and upload new firmware. Linux sees what looks like a drive going away without a user command to flush and unmount it, and pops up an alert to let you know something might have gone wrong.

I get similar messages on a Mac.

adafruit_support_mike
 
Posts: 42178
Joined: Thu Feb 11, 2010 2:51 pm

Re: metro m0 express: arduino IDE upload auto launches file

by Christopher123 on Sat Aug 12, 2017 10:02 pm

Hi adafruit_support_mike,

Thanks for the reply. Your reply details reminded me there is an OS behavior preference I can modify which eliminates this annoyance. For others using Linux Mint's File Manager (Nemo) this option is under Edit, Preferences, Behavior, Media Handling. I deselected all options under "media handling". No more auto launches when code is uploaded.

Thanks You!!!

Christopher123
 
Posts: 2
Joined: Mon Aug 07, 2017 6:56 pm

Re: metro m0 express: arduino IDE upload auto launches file

by adafruit_support_mike on Sun Aug 13, 2017 3:40 am

Nice.. thanks for posting the follow-up!

adafruit_support_mike
 
Posts: 42178
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.