0

Another LIS3MDL failure
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Another LIS3MDL failure

by w5hvs on Fri Jul 30, 2021 2:15 am

I have just the basic setup for the LIS3MDL board... just the board connected to an Arduino Nano using IC2 communications. Problem is the Adafruit's "lis3mdl_demo" sketch keeps failing with the message "Failed to find LIS3MDL chip". Also, when I ran Arduino’s “IC2_Scanner” sketch the address reported was “0x1E”. I had Amazon replace the board and the same error occurs.

Looking through the forum, the last reference to this error was by ‘adafruit2’ on ‘Sat Mar 12, 2005 12:36 am’ under the post “LIS3MDL begin_I2C failure”.

I will add the following info to this problem: With the replacement board powered up, I first ran the Arduino “IC2_Scanner” sketch with the resulting address to be "0x1C". Load and run the “lis3mdl_demo” sketch and get “failure” msg. Load and run “I2C_Scanner” sketch and now the address comes back as “0x1E”! Disconnect power from Nano, power back up, load and run “IC2_Scanner” sketch and the address is “0x1C” again. Run “lis3mdl_demo” sketch, get error msg, load and run scanner sketch and the address changed to “0x1E’!!! FYI... running Adafruit_LIS3MDL library, v 1.10... Something is not working correctly…. Please advise… thank you.

w5hvs
 
Posts: 3
Joined: Fri Jul 30, 2021 1:30 am

Re: Another LIS3MDL failure

by adafruit_support_bill on Fri Jul 30, 2021 5:40 am

Please post some photos showing all of your soldering and connections.

adafruit_support_bill
 
Posts: 81891
Joined: Sat Feb 07, 2009 10:11 am

Re: Another LIS3MDL failure

by w5hvs on Fri Jul 30, 2021 2:08 pm

As requested, photos attached...
LIS3MDL-1.jpg
LIS3MDL-1.jpg (123.68 KiB) Viewed 75 times

LIS3MDL-2.jpg
LIS3MDL-2.jpg (62.78 KiB) Viewed 75 times

w5hvs
 
Posts: 3
Joined: Fri Jul 30, 2021 1:30 am

Re: Another LIS3MDL failure

by adafruit_support_bill on Fri Jul 30, 2021 2:35 pm

Try connecting the DO pin to GND.

adafruit_support_bill
 
Posts: 81891
Joined: Sat Feb 07, 2009 10:11 am

Re: Another LIS3MDL failure

by w5hvs on Tue Aug 03, 2021 7:25 pm

Success! That fixed the problem! Hopefully you will update your website so that future “first timers” will not have to go thru the frustrations of “sketch errors”! Again, thank you for your help!

w5hvs
 
Posts: 3
Joined: Fri Jul 30, 2021 1:30 am

Please be positive and constructive with your questions and comments.