0

New NeoTrellis at 0x2d and not responsive
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

New NeoTrellis at 0x2d and not responsive

by ZapBlaster4000 on Thu Sep 16, 2021 6:24 pm

I just got a Adafruit 8x8 Feather M4 Kit Pack. It seems one of the 4x4 tiles may be defective. The other 3 seem to be working.

The defective tile appears as I2C address 0x2d, which is invalid according to https://learn.adafruit.com/adafruit-neotrellis/tiling

When I try to create a NeoTrellis with addr=0x2d it says no pullup detected, however I measure 10k from either SCL or SDA to the 3V i2c pad. And it does list as address 0x2d when scanned in CircuitPython 6.

The exact same code works with all three of the other NeoTrellis boards in the kit, which are now addressed 0x2f, 0x30,0x31.

I tried changing the address by closing A0 (with only the defective board connected) but the board still reported 0x2d. The other 3 tiles all change addresses correctly.

I tried linking the board via other tile pads rather than the jst connector with the same failure.

Upon visual inspection there isn't an apparent defect.

Is this a known issue? Is there a simple way to reflash the SAMD09, or at this point is it better just to replace the board?

ZapBlaster4000
 
Posts: 11
Joined: Wed Feb 17, 2021 12:38 am

Re: New NeoTrellis at 0x2d and not responsive

by adafruit_support_carter on Fri Sep 17, 2021 11:36 am

Can you post some photos of your setup so we can check the current state of the hardware.

adafruit_support_carter
 
Posts: 21359
Joined: Tue Nov 29, 2016 2:45 pm

Re: New NeoTrellis at 0x2d and not responsive

by ZapBlaster4000 on Fri Sep 17, 2021 8:25 pm

I have removed the defective board and tested it separately. The other three boards work fine (pictured assembled):
Assembled.jpg
Assembled.jpg (190.57 KiB) Viewed 58 times


Defective board bottom:
Defective.jpg
Defective.jpg (321.39 KiB) Viewed 58 times


Defective board top:
Defective2.jpg
Defective2.jpg (248.97 KiB) Viewed 58 times

ZapBlaster4000
 
Posts: 11
Joined: Wed Feb 17, 2021 12:38 am

Re: New NeoTrellis at 0x2d and not responsive

by ZapBlaster4000 on Fri Sep 17, 2021 8:30 pm

0x2d.jpg
0x2d.jpg (242.08 KiB) Viewed 58 times


0x2D isn't a valid address for the NeoTrellis Tile, the no-jumper addressing starts at 0x2E. Moreover the address didn't change if soldered the address jumper A0 to test.

ZapBlaster4000
 
Posts: 11
Joined: Wed Feb 17, 2021 12:38 am

Re: New NeoTrellis at 0x2d and not responsive

by ZapBlaster4000 on Sat Sep 18, 2021 1:23 pm

Is there anything else I need to do to get a replacement sent out?

What is the typical timeframe?

Amazon says they can deliver a new one by Monday if you want to just issue store credit.

ZapBlaster4000
 
Posts: 11
Joined: Wed Feb 17, 2021 12:38 am

Re: New NeoTrellis at 0x2d and not responsive

by ZapBlaster4000 on Mon Sep 20, 2021 12:37 am

It looks like the date code on all the boards, the good ones and the defective one is the same, 1921. ~May 10-16

ZapBlaster4000
 
Posts: 11
Joined: Wed Feb 17, 2021 12:38 am

Re: New NeoTrellis at 0x2d and not responsive

by adafruit2 on Mon Sep 20, 2021 12:54 pm

thats pretty weird - the default is 0x2e for sure, lets just replace it, email support@adafruit for a new one.

adafruit2
Site Admin
 
Posts: 20261
Joined: Fri Mar 11, 2005 7:36 pm

Re: New NeoTrellis at 0x2d and not responsive

by ZapBlaster4000 on Mon Sep 20, 2021 5:55 pm

Thanks, I will email support and reference this thread.

ZapBlaster4000
 
Posts: 11
Joined: Wed Feb 17, 2021 12:38 am

Re: New NeoTrellis at 0x2d and not responsive

by adafruit_support_carter on Mon Sep 20, 2021 5:58 pm

Yep. Reference this thread and include your order number in the email. They can send you a replacement NeoTrellis board.

adafruit_support_carter
 
Posts: 21359
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.