Due to high demand, expect some shipping delays at this time - orders may not ship for up to 2-3 business days.
0

BNO055 WebGL Demo - Potential Issues
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

BNO055 WebGL Demo - Potential Issues

by alapsansky on Wed Jan 26, 2022 9:36 pm

Hello everyone,

I posted this question on the Github page for the Adafruit BNO055 as well (https://github.com/adafruit/Adafruit_Ci ... hon_BNO055), but I wanted to check here to see if anyone has a simple fix.

I think I have found an issue with the WebGL demo of the BNO055 sensor. However, I want to confirm that this is just an issue with the example code and visualization, and not with the data collected from the sensor.

When I run the demo, the motion of the 3D model in the WebGL example does not reflect the motion of the BNO055 sensor. Specifically, with the sensor on a flat surface with the VIN to RST pin holes facing away, a change in pitch of the sensor (which accurately changes the values next to "Pitch =") causes the model to roll. A change in roll causes the model to yaw. And a change in yaw causes the model to pitch.

The system shows a complete calibration. Because the Euler output seems correct, I am guessing that there is some issue with the order of the quaternions in the code, but I have not been successful with identifying the exact issue.

I have tested this with two sensors, using both a direct soldered connection and a QWIIC connector, to my Raspberry Pi Zero 2. Because the video included with the tutorial seems correct (https://learn.adafruit.com/adafruit-bno ... ion-sensor), I think it might be related to the recent updates with the code hosted on the Github page, but I cannot be sure.

Thank you for any help!

alapsansky
 
Posts: 1
Joined: Wed Jan 26, 2022 9:28 pm

Please be positive and constructive with your questions and comments.