0

Defect soils ensor?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Defect soils ensor?

by lapino89 on Wed Jul 06, 2022 9:36 am

Hi, i´ve been troubleshooting for some time now and can now say 100% I got a defective soil sensor. Bough 4 sensors and could not by the life of me get the first test setup to get me any readings. Been through every step checking older seesaw firmwares, changed arduino cards, checked connection and that the sensor got the correct voltage etc. Used the example code from your library for first test when not getting it to work.

Found this on the forum: viewtopic.php?f=19&t=190690&p=922628&hilit=ERROR%21+seesaw+not+found#p922628

And used the I2C scanner as shown under and it did not find anything before changing the sensor to one of the others I bought. Tried on multiple boards with no luck, 1 was faulty and 3 working.

Anything else I could do? looks like the answer on the older forum was that it was probably defect.


best
Eirik
Attachments
Skjermbilde 2022-07-06 kl. 12.15.05.png
Skjermbilde 2022-07-06 kl. 12.15.05.png (17.03 KiB) Viewed 108 times

lapino89
 
Posts: 3
Joined: Wed Jul 06, 2022 9:16 am

Re: Defect soils ensor?

by dastels on Wed Jul 06, 2022 10:47 am

All 4 were tested in identical circumstances (cable, connection, etc)?

Dave

dastels
 
Posts: 10535
Joined: Tue Oct 20, 2015 3:22 pm

Re: Defect soils ensor?

by lapino89 on Wed Jul 06, 2022 11:32 am

Yes, first i thought i Was doing something wrong with libraries or having communication problem. When I then got the second one to work, I tested all of them with that exact setup. And did extra test on the one that did not connect to be sure. Both running program and scan several times, measuring that it did get 5V and had contact through pins

lapino89
 
Posts: 3
Joined: Wed Jul 06, 2022 9:16 am

Re: Defect soils ensor?

by dastels on Wed Jul 06, 2022 4:39 pm

Just to confirm, it's this product: https://www.adafruit.com/product/4026.

Dave

dastels
 
Posts: 10535
Joined: Tue Oct 20, 2015 3:22 pm

Re: Defect soils ensor?

by lapino89 on Wed Jul 06, 2022 5:06 pm

Yes, correct. Bought them from digikey. Later Found out that there is a local dealer in Oslo.

It Was the i2c that made me think I Was doing something wrong. But only followed instructions from your site so could not understand Why it Was not working untill I read on the forum and opened all of them to test all.

lapino89
 
Posts: 3
Joined: Wed Jul 06, 2022 9:16 am

Re: Defect soils ensor?

by dastels on Wed Jul 06, 2022 7:16 pm

OK. You need to go to Digikey for a replacement. If it had been directly from Adafruit I'd authorize a replacement. Feel free to show them this thread to support your claim.

Dave

dastels
 
Posts: 10535
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.