Black Lives Matter - Action and Equality. ... Adafruit joins the Stop Hate for Profit campaign.
0

USB Digital Microscope Connectivity Issue
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

USB Digital Microscope Connectivity Issue

by franenjayy on Thu Jan 04, 2018 11:31 am

Hello,

I had purchased your "USB Microscope - 5MP interpolated 220x magnification / 8 LEDs" (product ID 636) a while back and it has worked fine up until this point. I had the microscope connected to my PC and opened MicroCapture. Everything appeared to work fine for the first 10-15 seconds but then the image just went black. I tried restarting MicroCapture and it gave the message "No device detected, please connect your microscope directly to your PC USP port." I tried inserting the microscope into another USB port and had the same issue. Despite MicroCapture not recognizing the device is inserted into the USB port, the LED's on the microscope work fine and I have tried inserting other devices into the same port with no issues, so I am pretty sure it is not an issue with the port.

I next decided to uninstall and reinstall the driver and software, but when I try to run the USB microscope driver from the install CD, it gives a message saying "no find match device, please insert camera first." I tried looking under the PC's device manager but could not find the microscope anywhere. I also tried plugging the microscope into a different PC. Normally a message pops up saying that a new device has been found but this did not occur. I checked the device manager on the second PC and could not find the microscope anywhere.

Unfortunately, I am completely at a loss as to how I can resolve this issue and was hoping that you might have some suggestions. Thanks!

franenjayy
 
Posts: 2
Joined: Mon Jun 20, 2016 11:51 am

Re: USB Digital Microscope Connectivity Issue

by giarc on Tue Mar 06, 2018 10:09 am

I am having a similar problem, The Microscope was working fine yesterday and again this morning. I was adjusting the scope and the image went black (LEDs still lit.) I tried rebooting the machine, and trying another computer with the software. The computer appears to recognize that the microscope is there, and I can even take a snapshot, but I just get a black image. My first guess is that the image sensor went out. Not sure how to proceed. Any recommendations?

giarc
 
Posts: 1
Joined: Fri Jun 03, 2011 11:03 am

Re: USB Digital Microscope Connectivity Issue

by ggutleben on Mon Apr 30, 2018 1:15 pm

I'm not getting very far ! I can't get this to run on Windows 2000. It doesn't recognize the microscope but the program does appear to be running. I tried rebooting,no go. Also will this software run on Windows 10? Maybe the problem is my old laptop!
Thank you

ggutleben
 
Posts: 1
Joined: Mon Apr 30, 2018 12:51 pm

Re: USB Digital Microscope Connectivity Issue

by The_EngiNERD on Mon Jul 16, 2018 8:45 am

I am having a different issue with the USB Microscope...

I'm running Windows 10 and the device is recognized in the Device Manager as:

Venus USB2.0 Camera

The driver installer software that is included on the cd and through the download at https://www.adafruit.com/product/636 has installers and driver files from 2011 at the latest. The website for the microscope manufacturer (https://veho-world.com/product/veho-usb-microscope-400x-magnification/) does not have a software download but does claim that the device is compatible with Windows 10. Further, I found (this release) from the manufacturer.

Adafruit, please help locate the current drivers for the product you are selling. If the products cannot beet the specifications as advertised customers will expect full refunds on their products.

Thank you

The_EngiNERD
 
Posts: 1
Joined: Mon Jul 16, 2018 8:36 am

Re: USB Digital Microscope Connectivity Issue

by HarpDude on Wed Aug 14, 2019 8:23 pm

Was unable to get the USB microscope and drivers to work with Windows 10. Tried downloading the "freshest" windows drivers from a variety of sources and although the camera device is detected by USB, the supplied imaging application is unable to render an image.

Sent a message to support@adafruit.com a few days ago and am awaiting a return authorization.

If this is a common issue, I suggest noting that in the product description.

HarpDude
 
Posts: 169
Joined: Mon Dec 07, 2015 2:52 am

Re: USB Digital Microscope Connectivity Issue

by adafruit2 on Thu Aug 15, 2019 1:23 pm

harp, hiya - does it show up as an 'every day' camera? (like a webcam)

adafruit2
Site Admin
 
Posts: 19222
Joined: Fri Mar 11, 2005 7:36 pm

Re: USB Digital Microscope Connectivity Issue

by HarpDude on Thu Aug 15, 2019 4:02 pm

No it doesn't. The documentation states that it can only appear in applications that utilize the fundamental driver.

HarpDude
 
Posts: 169
Joined: Mon Dec 07, 2015 2:52 am

Re: USB Digital Microscope Connectivity Issue

by adafruit2 on Thu Aug 15, 2019 4:12 pm

hmm lets try replacing it - email support@adafruit for a new camera. let us know if that doesnt fix it!

adafruit2
Site Admin
 
Posts: 19222
Joined: Fri Mar 11, 2005 7:36 pm

Re: USB Digital Microscope Connectivity Issue

by HarpDude on Thu Aug 15, 2019 4:38 pm

Will do. Thanks!

HarpDude
 
Posts: 169
Joined: Mon Dec 07, 2015 2:52 am

Re: USB Digital Microscope Connectivity Issue

by HarpDude on Sat Aug 24, 2019 12:02 am

Thank you -- the replacement microscope is working! This one is showing up as an imaging device.

ad9833 wing micro 800_640.jpg
ad9833 wing micro 800_640.jpg (745.09 KiB) Viewed 681 times


device mgr designation.png
device mgr designation.png (8.75 KiB) Viewed 680 times

HarpDude
 
Posts: 169
Joined: Mon Dec 07, 2015 2:52 am

Re: USB Digital Microscope Connectivity Issue

by adafruit2 on Sat Aug 24, 2019 12:20 pm

nice! thank you for the followup :)

adafruit2
Site Admin
 
Posts: 19222
Joined: Fri Mar 11, 2005 7:36 pm

Re: USB Digital Microscope Connectivity Issue

by HarpDude on Sat Aug 24, 2019 12:38 pm

Also, just found the problem with the first 'scope. The internal PCB connector for the USB cable had two loose crimp contact pins (power, D+) that weren't fully inserted. The most difficult part of the fix was figuring out how to open the case. The domed end cap can be released with a quarter-turn (no tools).

HarpDude
 
Posts: 169
Joined: Mon Dec 07, 2015 2:52 am

Re: USB Digital Microscope Connectivity Issue

by lanvocado on Tue Oct 29, 2019 5:25 pm

Hello,

I've just purchased the Adafruit USB Microscope (https://www.adafruit.com/product/636), installed the driver and software from the companion CD but I couldn't seem to get it to work. When I double click the "Microcapture" icon which was generated after I've installed the software, it doesn't launch the software, instead I'm getting a "Missing Shortcut" menu popped up as shown in attachment. I'm using Windows 10 OS in my computer. Is this USB microscope compatible with Windows 10?. Would you please advise how to debug this issue?.

Thanks,
Attachments
1.PNG
1.PNG (46.29 KiB) Viewed 465 times

lanvocado
 
Posts: 3
Joined: Tue Oct 29, 2019 4:34 pm

Re: USB Digital Microscope Connectivity Issue

by adafruit2 on Tue Oct 29, 2019 7:44 pm

hiya lan, this is a new/different issue which is unrelated to the original post. please start a new thread :)

adafruit2
Site Admin
 
Posts: 19222
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.