0

ESP32 Wrover Kit Issues
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

ESP32 Wrover Kit Issues

by MikeDaoust on Thu Jan 04, 2018 1:53 pm

Hello there,

We had ordered a ESP32 WROVER unit from you and are currently having many difficulties building to the board. Upon doing a search online, we’ve found that our issue is quite common. The program itself fails to build to the board using a variety of different development setups, and the issue seems related to a lower level connection issue.

In short, every time we try to build to the board we see the following issue:

"Connecting........_____....._____....._____....._____....._____....._____....._____....._____....._____....._____

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header”

We have tried the following:
    Holding the boot button as I build
    Holding the boot button as I build, then releasing it shortly in.
    Turning the device off, holding the boot button, turning the device on, then flashing
    Unplugging the device, turning it off, holding the boot butting, turning the device back on, plugging it in, then flashing,
    Doing the same 4 steps with the EN button
    Doing the same 4 steps with the EN AND Boot Buttons, and releasing each at different stages in an exhaustive attempt to make things work.
    Using a totally different computer to build from
    Using both ESP IDF and the ESP Arduino framework in PlatformIO
    Grounding GPIO2 prior to, and during flashing
    Building both plugged into a breadboard, and sitting on top of a static free surface
    Using both platformIO and the command line to attempt the build
    Using bare minimal empty projects.
    Using known code that have worked for other people.
    Finally, after failing everything else, re-soldering the ESP32 unit to the development board.
    We have attempted to build using both Mac and PC development setups and using both Arduino and espressif_idf.

At this point, we are quite stumped. If at all possible, we were wondering if it is possible we have a defective board, and if so, if we could receive a replacement in its stead. I can provide the original order details if needed.

Thank you!

MikeDaoust
 
Posts: 1
Joined: Thu Jan 04, 2018 1:52 pm

Re: ESP32 Wrover Kit Issues

by AnalogBubblebath on Thu Feb 15, 2018 7:10 pm

MikeDaoust wrote:Hello there,

We had ordered a ESP32 WROVER unit from you and are currently having many difficulties building to the board. Upon doing a search online, we’ve found that our issue is quite common. The program itself fails to build to the board using a variety of different development setups, and the issue seems related to a lower level connection issue.

In short, every time we try to build to the board we see the following issue:

"Connecting........_____....._____....._____....._____....._____....._____....._____....._____....._____....._____

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header”

We have tried the following:
    Holding the boot button as I build
    Holding the boot button as I build, then releasing it shortly in.
    Turning the device off, holding the boot button, turning the device on, then flashing
    Unplugging the device, turning it off, holding the boot butting, turning the device back on, plugging it in, then flashing,
    Doing the same 4 steps with the EN button
    Doing the same 4 steps with the EN AND Boot Buttons, and releasing each at different stages in an exhaustive attempt to make things work.
    Using a totally different computer to build from
    Using both ESP IDF and the ESP Arduino framework in PlatformIO
    Grounding GPIO2 prior to, and during flashing
    Building both plugged into a breadboard, and sitting on top of a static free surface
    Using both platformIO and the command line to attempt the build
    Using bare minimal empty projects.
    Using known code that have worked for other people.
    Finally, after failing everything else, re-soldering the ESP32 unit to the development board.
    We have attempted to build using both Mac and PC development setups and using both Arduino and espressif_idf.

At this point, we are quite stumped. If at all possible, we were wondering if it is possible we have a defective board, and if so, if we could receive a replacement in its stead. I can provide the original order details if needed.

Thank you!


I am having the same problem and thinking my board may be faulty. I've gone through all of the Adafruit tutorials and installed all drivers and esp tools.

AnalogBubblebath
 
Posts: 4
Joined: Mon Jan 29, 2018 11:13 pm

Re: ESP32 Wrover Kit Issues

by JohnsonUTPB on Sat Feb 24, 2018 1:03 pm

This is a Me Too post:( I have come to the conclusion that I have a defective product. Fortunately, It didn't cost me as much time to figure this out because I bought TWO. However, and not my primary concern, the battery/voltage controller circuit also seems to be defective. These issues need immediate attention and this topic needs more support!!!

JohnsonUTPB
 
Posts: 9
Joined: Fri Jun 24, 2016 1:21 am

Re: ESP32 Wrover Kit Issues

by skipole on Thu Mar 08, 2018 1:04 pm

Me three. Having same problems and tried all the things that both posters did. I tried the install on both Mac OS High Sierra on Mac Laptop and on Windows 10 ASUS Aspire Switch 10. Software appears to install properly on both computers but when I run make flash it crashes as indicated below.

Also how is the display on the board supposed to function in the demo mode. Mine shows a square changing color in sync with the RGB Led but not the whole display.

skipole
 
Posts: 5
Joined: Fri May 05, 2017 1:32 pm

Please be positive and constructive with your questions and comments.