0

Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz WiFi
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz WiFi

by davew_wu on Sun Dec 23, 2018 3:54 am

I purchased https://www.adafruit.com/product/3974 a few weeks ago. Just had a chance to put it together today, following tutorial https://learn.adafruit.com/pi-hole-ad-p ... y/overview. I was able to install all the scripts and configs following the nicely written instructions. However, after I completed PiTFT config and installed PADD (and reboot). The console was not shown on the TFT display. Since the above bundle product uses 2.8" TFT, I selected "1" (see below) during the installation process b/c that seemed to match my hardware.

Select configuration:
1. PiTFT 2.4", 2.8" or 3.2" resistive (240x320)
2. PiTFT 2.2" no touch (240x320)
3. PiTFT 2.8" capacitive touch (240x320)
4. PiTFT 3.5" resistive touch (320x480)
5. Quit without installing

However, I have also tried to select "4" as in instructions but it still doesn't work. If I run .bashrc on my computer in ssh, I can see that PADD is working and running. Can you please advise how I can debug to get it work?

The second question I have is that I can see the WiFi is only setting up as 2.4GHz network. Since I am using RPi3B+, I'd like to also enable 5GHz WiFi. Do you have instructions to do that?

Thanks,
Dave

davew_wu
 
Posts: 14
Joined: Sun Jul 23, 2017 1:07 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by davew_wu on Mon Dec 24, 2018 12:51 am

A few more info:
1. When I ran ./padd.sh from my computer terminal, the PADD seemed to be running fine but I did get the below warning:
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

2. If I connected an external (HDMI) monitor, after the sudo reboot, the console output will stop at:
Starting Set console font and keymap...

The log before above line is
Starting Tell Plymouth to Write Out Runtime Data...

3. If I do sudo reboot again, it seemed to proceed execution further. This time will hang at
[OK] Reached target Remote File Systems.

4. I can repeat the above process a few times and it seemed every time it will execute a few more steps. If I do a normal shutdown and reconnect the power. The first boot will stop at below console log.
[OK] Started Update UTMP about System Boot/Shutdown.

Hope this provides a bit more useful info.

davew_wu
 
Posts: 14
Joined: Sun Jul 23, 2017 1:07 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by davew_wu on Sat Jan 12, 2019 3:26 am

Can any staff from Adafruit please assist in answering this post?
Thanks

davew_wu
 
Posts: 14
Joined: Sun Jul 23, 2017 1:07 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by adafruit_support_carter on Thu Jan 17, 2019 2:41 pm

This:
1. PiTFT 2.4", 2.8" or 3.2" resistive (240x320)

was the correct option for the screen you have. But what did you select for the remaining options?

Try running raspi-config and setting your locale. That might help with that warning about setlocale.

adafruit_support_carter
 
Posts: 9792
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by davew_wu on Mon Jan 21, 2019 4:24 am

I ran raspi-config and changed locale successfully this time (I didn't use spacebar to mark the selection before). So, the warning no longer appears. However, the PiTFT is still not working. I re-ran the adafruit-pitft.sh again but wasn't successful. Please scroll down to see the error message.

pi@pi-hole:~ $ sudo ./adafruit-pitft.sh

This script downloads and installs
PiTFT Support using userspace touch
controls and a DTO for display drawing.
one of several configuration files.
Run time of up to 5 minutes. Reboot required!

Select configuration:
1. PiTFT 2.4", 2.8" or 3.2" resistive (240x320)
2. PiTFT 2.2" no touch (240x320)
3. PiTFT 2.8" capacitive touch (240x320)
4. PiTFT 3.5" resistive touch (320x480)
5. Quit without installing

SELECT 1-5: 1
Select rotation:
1. 90 degrees (landscape)
2. 180 degrees (portait)
3. 270 degrees (landscape)
4. 0 degrees (portait)

SELECT 1-4: 3
[PITFT] Checking init system...
Found systemd
/boot is mounted
[PITFT] System update
Updating apt indexes...
.........
E: The repository 'http://archive.raspberrypi.org/debian stretch Release' does no longer have a Release file.
WARNING : Apt failed to update indexes!

davew_wu
 
Posts: 14
Joined: Sun Jul 23, 2017 1:07 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by adafruit_support_carter on Mon Jan 21, 2019 11:56 am

What version of Raspbian are you using?

adafruit_support_carter
 
Posts: 9792
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by davew_wu on Mon Jan 21, 2019 2:13 pm

pi@pi-hole:~ $ uname -a
Linux pi-hole 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux

davew_wu
 
Posts: 14
Joined: Sun Jul 23, 2017 1:07 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by davew_wu on Mon Jan 21, 2019 2:15 pm

pi@pi-hole:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

davew_wu
 
Posts: 14
Joined: Sun Jul 23, 2017 1:07 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by adafruit_support_carter on Mon Jan 21, 2019 2:53 pm

Is the Pi connected to the internet? We can't recreate this.

What if you just try to run apt from command line?
Code: Select all | TOGGLE FULL SIZE
sudo apt-get update

adafruit_support_carter
 
Posts: 9792
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by davew_wu on Mon Jan 21, 2019 3:19 pm

I tried to do this already. But it somehow didn't get completed. I am doing it again.

pi@pi-hole:~ $ sudo apt-get update
Get:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
0% [2 InRelease 22.8 kB/25.4 kB 90%]packet_write_wait: Connection to 10.0.1.138 port 22: Broken pipe

davew_wu
 
Posts: 14
Joined: Sun Jul 23, 2017 1:07 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by adafruit_support_carter on Mon Jan 21, 2019 3:35 pm

Seems like something is happening with basic network connectivity. See if you can figure out what that might be and just keep trying to get that update command to run successfully.

adafruit_support_carter
 
Posts: 9792
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by davew_wu on Mon Jan 21, 2019 5:08 pm

I was able to successfully run "sudo apt-get update" and "sudo apt-get dist-upgrade". Re-ran adafruit-pitft.sh. It's successful this time but PADD is still not running on my PiTFT. Are there any CLI commands I can run to ensure the PiTFT is working? Thanks.

pi@pi-hole:~ $ sudo ./adafruit-pitft.sh

This script downloads and installs
PiTFT Support using userspace touch
controls and a DTO for display drawing.
one of several configuration files.
Run time of up to 5 minutes. Reboot required!

Select configuration:
1. PiTFT 2.4", 2.8" or 3.2" resistive (240x320)
2. PiTFT 2.2" no touch (240x320)
3. PiTFT 2.8" capacitive touch (240x320)
4. PiTFT 3.5" resistive touch (320x480)
5. Quit without installing

SELECT 1-5: 1
Select rotation:
1. 90 degrees (landscape)
2. 180 degrees (portait)
3. 270 degrees (landscape)
4. 0 degrees (portait)

SELECT 1-4: 3
[PITFT] Checking init system...
Found systemd
/boot is mounted
[PITFT] System update
Updating apt indexes...
.........
Reading package lists...
.........
[PITFT] Installing Python libraries & Software...
Installing Pre-requisite Software...This may take a few minutes!
[PITFT] Updating /boot/config.txt...
Already have an adafruit-pitft-helper section in /boot/config.txt.
Removing old section...
[PITFT] Updating SysFS rules for Touchscreen...
[PITFT] Updating TSLib default calibration...
Would you like the console to appear on the PiTFT display? [y/n] y
[PITFT] Updating console to PiTFT...
Remove fbcp from /etc/rc.local, if it's there...
Configuring boot/config.txt for default HDMI
Set up main console turn on
/boot/cmdline.txt already updated
Turning off console blanking
Setting raspi-config to boot to console w/o login...
[PITFT] Success!

Settings take effect on next boot.

REBOOT NOW? [y/N] y

davew_wu
 
Posts: 14
Joined: Sun Jul 23, 2017 1:07 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by adafruit_support_carter on Mon Jan 21, 2019 9:24 pm

PADD is a separate thing that comes after setting up the PiTFT. Is the PiTFT working now? When you reboot do you see the console message appearing?

adafruit_support_carter
 
Posts: 9792
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by davew_wu on Mon Jan 21, 2019 9:33 pm

No, I didn’t see the console show up on the PiTFT.

davew_wu
 
Posts: 14
Joined: Sun Jul 23, 2017 1:07 pm

Re: Pi-Hole 2.8" PiTFT doesn't work and how to enable 5GHz W

by adafruit_support_carter on Mon Jan 21, 2019 10:01 pm

Can you try starting again with a fresh copy of Raspbian. It's possible some of the earlier attempts that ran into network issues have left these in weird state. Don't worry about PADD or Pi-Hole at this point. We're just trying to get the TFT to show the console.

adafruit_support_carter
 
Posts: 9792
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.