0

RF M4 and Keyfob unresponsive
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

RF M4 and Keyfob unresponsive

by Amorphis984 on Fri Dec 28, 2018 5:03 pm

I writing about the Simple RF M4 Receiver, order number 1932775, purchased on 12/14/20018. In testing the component prior to using it on my project, I connected the receiver to a breadboard and hooked up the LED's and the 220-ohm resistors as follows. Since no documentation or schematic was furnished with the receiver, I observed the image and video on the Adafruit website in order to properly hook up the receiver. I used a regulated power supply on my workbench to supply 5VDC and ground to the breadboard. Leads from the breadboard's 5V and ground terminals were hooked to the receiver's 5V and ground respectively. The LEDs anode was connected to the receiver's D0..D3 and the cathodes were connected through 200-ohm resistors and connected to ground. An Agilent 34401A multimeter was used to ensure that 5VDC was applied to the circuit. A keyfob purchased from Adafruit, product ID: 1095, was used to test the receiver but failed to activate any of the LEDs. LEDs were tested separately and were found to function properly. I welcome any suggestions for making the two RF M4 work. If my procedure is found to be valid and no other solution is available, I would like to return the two receivers for a refund.
Attachments
Equipment.jpg
Test Setup
Equipment.jpg (228.05 KiB) Viewed 152 times
Voltage applied.jpg
Votage applied
Voltage applied.jpg (222.26 KiB) Viewed 152 times
Key Pressed.jpg
Keyfob key pressed
Key Pressed.jpg (164.55 KiB) Viewed 152 times

Amorphis984
 
Posts: 3
Joined: Fri Dec 28, 2018 1:30 pm

Re: RF M4 and Keyfob unresponsive

by franklin97355 on Fri Dec 28, 2018 5:11 pm

In a couple of your pictures you have jumpers plugged into the power rail but no jumpers to that rail from the power supply or receiver. Please post a clear picture from above so we can see all your connections.

franklin97355
 
Posts: 20127
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: RF M4 and Keyfob unresponsive

by Amorphis984 on Mon Dec 31, 2018 1:46 pm

I posted the wrong test image before. Attached is the correct image. I hope this is a better view.
Attachments
RF M4 Test.jpg
RF M4 Test
RF M4 Test.jpg (202.04 KiB) Viewed 122 times

Amorphis984
 
Posts: 3
Joined: Fri Dec 28, 2018 1:30 pm

Re: RF M4 and Keyfob unresponsive

by adafruit_support_carter on Mon Jan 07, 2019 12:23 pm

The fact that this is happening to two of them warrants a little further investigation. A few more things to check:

  • Can you measure the voltage directly at the receiver to make sure power is getting there and rule out a bad jumper wire
  • Is the remote LED coming on when you press a button? Looks like it is in your photo, but not sure if it's just reflection.
  • How fresh are the batteries in the remote?
  • And let's make sure you have the M variant. There should be an "M" in the label on the chip, see below.
remote.jpg
remote.jpg (15.47 KiB) Viewed 98 times

adafruit_support_carter
 
Posts: 9792
Joined: Tue Nov 29, 2016 2:45 pm

Re: RF M4 and Keyfob unresponsive

by Amorphis984 on Tue Jan 08, 2019 3:52 pm

Changing the batteries in my remote was the first thing I thought was the problem, so I replaced it with a fresh one. I did check the voltage at the receiver and it is getting 5V. No LED ever came on. I did check to make sure I was using the M version since I want the unit to be momentary when the keyfob is pressed. I don't want the L or T unit versions since it doesn't fit my project needs. I have worked with the PT2272-M4 chip on several remote projects and have found it problematic. I purchased your receiver unit in an effort to save time by just plugging your receive into my circuit rather than designing the receiver circuit from scratch. There is not much that I can offer that will help resolve this problem.

I'm a freelance electrical engineer with a Master's degree. I have tried everything to make these two receivers work without success.

Amorphis984
 
Posts: 3
Joined: Fri Dec 28, 2018 1:30 pm

Re: RF M4 and Keyfob unresponsive

by franklin97355 on Tue Jan 08, 2019 4:37 pm

Please contact support@adafruit.com with a link to this topic and they will get you a refund. Since both don't work our product may not work for you, sorry.

franklin97355
 
Posts: 20127
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Please be positive and constructive with your questions and comments.