0

SHT-30 sensor will not power on
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

SHT-30 sensor will not power on

by porcupal on Sun Aug 04, 2019 9:12 pm

The product is an SHT-30 Temperature and Humidity sensor, order number: 2106560-3889284842, which was ordered on July 29, 2019.

Here is a shot of the entire test before connecting the lead wire to power.
IMG_2872.jpg
before connecting the lead wire to power
IMG_2872.jpg (925.04 KiB) Viewed 360 times


After connecting the lead wire, powering the SHT-30 via 3.3V, which is still not being detected by i2cdetect.
IMG_2874.jpg
after powering the SHT-30 via 3.3v
IMG_2874.jpg (920.59 KiB) Viewed 360 times


A close-up of the pinouts, which also shows the output of i2cdetect.
IMG_2867.jpg
close-up of the pinouts and i2cdetect output
IMG_2867.jpg (670.35 KiB) Viewed 360 times


Please advise how to return

porcupal
 
Posts: 8
Joined: Sun Aug 04, 2019 8:36 pm

Re: SHT-30 sensor will not power on

by franklin97355 on Sun Aug 04, 2019 9:54 pm

First off, don't place your Pi on the static bag or any other conductive surface. Second, have to tested the power leads to make sure you are getting power to the sensor?

franklin97355
 
Posts: 21211
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: SHT-30 sensor will not power on

by porcupal on Tue Aug 06, 2019 3:28 am

I can confirm that I tested with a multimeter to verify that the SHT30 sensor is receiving power, and can provide pictures of that test if necessary. Here is an image of a different sensor that I tested with a multimeter to ensure that the RasbPi was supplying power.

Also, I noted your advice about the antistatic bag, this is just an older picture from before your comment.
IMG_2761.jpg
adxl345 sensor test with voltmeter readings
IMG_2761.jpg (983.55 KiB) Viewed 327 times

porcupal
 
Posts: 8
Joined: Sun Aug 04, 2019 8:36 pm

Re: SHT-30 sensor will not power on

by porcupal on Wed Aug 14, 2019 4:10 pm

Any other recommendations for this issue? I am still waiting for either a return or exchange, thank you.

porcupal
 
Posts: 8
Joined: Sun Aug 04, 2019 8:36 pm

Re: SHT-30 sensor will not power on

by adafruit_support_carter on Fri Aug 16, 2019 6:46 pm

What style headers are on the Pi Zero? Pre-installed (Pi Zero WH), hammer style, soldered yourself?

Can you get that ADXL345 breakout to show up with the I2C scan?

adafruit_support_carter
 
Posts: 13185
Joined: Tue Nov 29, 2016 2:45 pm

Re: SHT-30 sensor will not power on

by porcupal on Fri Aug 16, 2019 7:31 pm

The Raspberry Pi shown had pre-installed headers (Pi Zero WH), here is another photo that shows the Pi interfacing with two I2C devices, with the output on i2cdetect shown:
IMG_2766.jpg
ADXL345 and adafruit VEML6075 sensors connected to a Pi Zero WH
IMG_2766.jpg (863.47 KiB) Viewed 226 times

IMG_2767.jpg
a shot of the i2cdetect output, which correctly shows the ADXL345 on channel 53 and the VEML6075 on channel 10
IMG_2767.jpg (694.56 KiB) Viewed 226 times

porcupal
 
Posts: 8
Joined: Sun Aug 04, 2019 8:36 pm

Re: SHT-30 sensor will not power on

by franklin97355 on Fri Aug 16, 2019 9:17 pm

Do you have wires or headers soldered to the sensor boards?

franklin97355
 
Posts: 21211
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: SHT-30 sensor will not power on

by porcupal on Fri Aug 16, 2019 9:27 pm

No, there were no wires or headers soldered to either of the sensors. Simple jumper wires were used for all of the connections.

porcupal
 
Posts: 8
Joined: Sun Aug 04, 2019 8:36 pm

Re: SHT-30 sensor will not power on

by franklin97355 on Fri Aug 16, 2019 10:05 pm

you need to have soldered connections on those boards to make reliable connections. Solder on headers and try again.

franklin97355
 
Posts: 21211
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: SHT-30 sensor will not power on

by porcupal on Fri Aug 16, 2019 10:25 pm

The SHT-30 sensor does not have connections to solder to. It has exposed wires to which I connected alligator clips as shown in the first post.

porcupal
 
Posts: 8
Joined: Sun Aug 04, 2019 8:36 pm

Re: SHT-30 sensor will not power on

by adafruit_support_carter on Tue Aug 20, 2019 1:34 pm

It could be a similar issue - the alligator clips to jumpers aren't solid enough to reliably carry the I2C traffic. Good enough for an address scan, but not heavier traffic.

Can you try and make the connections to the Pi a little more directly somehow? Looks like you have alligator-to-alligator and female-to-male jumper wires. What other options do you have?

Also - do you have a non-Pi board like an Arduino that could be used for testing?

adafruit_support_carter
 
Posts: 13185
Joined: Tue Nov 29, 2016 2:45 pm

Re: SHT-30 sensor will not power on

by porcupal on Sun Sep 15, 2019 4:24 pm

I soldered the sensor directly to jumpers and tested again with a Raspberry Pi. Unfortunately I do not have an Arduino board to test with.

IMG_3837 copy.jpg
i2cdetect output
IMG_3837 copy.jpg (1017.01 KiB) Viewed 105 times


IMG_3840 copy.jpg
close up of the pinouts
IMG_3840 copy.jpg (1004.29 KiB) Viewed 105 times

porcupal
 
Posts: 8
Joined: Sun Aug 04, 2019 8:36 pm

Re: SHT-30 sensor will not power on

by adafruit_support_carter on Mon Sep 16, 2019 12:01 pm

Nice. That looks much cleaner. Try moving power to 3V and run i2cdetect again.

adafruit_support_carter
 
Posts: 13185
Joined: Tue Nov 29, 2016 2:45 pm

Re: SHT-30 sensor will not power on

by porcupal on Fri Sep 20, 2019 5:18 pm

IMG_3906 copy.jpg
connected to 3.3v
IMG_3906 copy.jpg (560 KiB) Viewed 53 times

IMG_3909 copy.jpg
pinouts
IMG_3909 copy.jpg (886.44 KiB) Viewed 53 times

IMG_3911 copy.jpg
i2cdetect display
IMG_3911 copy.jpg (572.54 KiB) Viewed 53 times

porcupal
 
Posts: 8
Joined: Sun Aug 04, 2019 8:36 pm

Re: SHT-30 sensor will not power on

by franklin97355 on Fri Sep 20, 2019 5:39 pm

Try swapping the data lines.

franklin97355
 
Posts: 21211
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Please be positive and constructive with your questions and comments.