Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Powerboost 500C no power output
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Powerboost 500C no power output

by Yetibob on Sat Aug 08, 2020 9:45 pm

I am having some issues with my Powerboost 500C that I recently got. The first time I plugged a battery in for a quick test everything seemed to be working fine. I came back to it about an hour later and for some reason it just stopped working. The blue light doesn't come on, the green "done" light should have come on by now. I charged the battery separately with a micro lop charger https://www.adafruit.com/product/4410 up top full, then plugged the battery back into the Powerboost 500C and it still has been showing as charging. Also, the board seems to get incredibly hot whenever I hook it up to my arduino via the USB A port that I soldered to the board. However it was having this issue right before I soldered the USB port to the board, I figured maybe the blue light just wouldn't come on without a connection so went ahead and attached it. The low bat light does briefly blink upon plugging the battery into the JST connector.

Image
Image
Image

Yetibob
 
Posts: 4
Joined: Sat Aug 08, 2020 9:31 pm

Re: Powerboost 500C no power output

by adafruit_support_carter on Mon Aug 10, 2020 1:18 pm

The images didn't get posted for some reason. Can you please try again.

What LiPo battery are you using?

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Powerboost 500C no power output

by Yetibob on Mon Aug 10, 2020 2:20 pm

Hmm, thats weird, trying again. As for the LiPo batteries I have 2 of these and the issue seems to occur with both of them.

https://www.adafruit.com/product/1578

iGBjf6s.jpg
iGBjf6s.jpg (200.88 KiB) Viewed 16 times

F2H94es.jpg
F2H94es.jpg (182.47 KiB) Viewed 16 times

ayyXy6k.jpg
ayyXy6k.jpg (211.42 KiB) Viewed 16 times

Yetibob
 
Posts: 4
Joined: Sat Aug 08, 2020 9:31 pm

Re: Powerboost 500C no power output

by adafruit_support_carter on Mon Aug 10, 2020 2:48 pm

Thanks for the photos. That all looks fine. Let's try a replacement.

Send an email to support@adafruit.com with a link to this thread and your order number and they can send you a replacement Power Boost 500C.

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Powerboost 500C no power output

by Yetibob on Mon Aug 10, 2020 4:46 pm

I don't think I am going to be able to go down the replacement route, at least not here. I bought it through amazon and I don't think that is one of official distribution methods. I was really just hoping to see if I was doing something wrong or if there was something that I could do to do fix it or to further diagnose the issue. I will go through the seller on amazon to see if I can get a replacement through them. Thanks for the help thought!

Yetibob
 
Posts: 4
Joined: Sat Aug 08, 2020 9:31 pm

Re: Powerboost 500C no power output

by adafruit_support_carter on Mon Aug 10, 2020 5:50 pm

If it was an official Adafruit reseller:
https://www.adafruit.com/distributors
you can still email support@adafruit.com.

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Re: Powerboost 500C no power output

by Yetibob on Tue Aug 11, 2020 4:28 pm

Thanks, but they aren't anywhere on that list. No worries though, I don't mind going through the normal amazon channels for this.

Yetibob
 
Posts: 4
Joined: Sat Aug 08, 2020 9:31 pm

Please be positive and constructive with your questions and comments.