0

TMP007 Problem
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: TMP007 Problem

by adoran on Fri Nov 03, 2017 8:26 pm

Hi
Need to build a TMP007 onto of a Huzzah with esp8662- any recommendations as to how to stack these two together?

many thanks

Anthony

adoran
 
Posts: 8
Joined: Tue Sep 05, 2017 11:09 am

Re: TMP007 Problem

by adafruit_support_mike on Mon Nov 06, 2017 1:33 pm

Nothing special.. just connect the VCC, GND, and I2C pins.

adafruit_support_mike
 
Posts: 50680
Joined: Thu Feb 11, 2010 2:51 pm

Re: TMP007 Problem

by adoran on Mon Nov 06, 2017 4:39 pm

Thank you- have that in place on a breadboard - wanting to secure in an enclosure with the temp over the esp8662.
The holes are offset from the boards- any further suggestions?

adoran
 
Posts: 8
Joined: Tue Sep 05, 2017 11:09 am

Re: TMP007 Problem

by adafruit_support_mike on Sun Nov 12, 2017 5:03 am

You'll need to provide some more detail.. which holes, and which boards?

adafruit_support_mike
 
Posts: 50680
Joined: Thu Feb 11, 2010 2:51 pm

Re: TMP007 Problem

by adoran on Sun Nov 12, 2017 7:37 am

Gnd and v battery on huzzah to tmp007 and Sda and Scl to gpio 4 and 5

Ideally a huzzah with the tmp007 built onboard would be ideal!

adoran
 
Posts: 8
Joined: Tue Sep 05, 2017 11:09 am

Re: TMP007 Problem

by adafruit_support_mike on Mon Nov 13, 2017 1:09 am

That isn't likely to happen any time soon, and it's easy to wire boards together using 30-gauge wire for any connections that don't overlap each other on the footprints. Breadboards are designed for connections made with jumper wires, so I'm unclear on what the technical problem is.

adafruit_support_mike
 
Posts: 50680
Joined: Thu Feb 11, 2010 2:51 pm

Re: TMP007 Problem

by adoran on Mon Dec 04, 2017 11:41 am

Hi Mike
Thank you for the previous comments-
I am on my 3rd tmp006 and when I solder the components to a header for my setup I get the dreaded no sensor found - albeit the 8266 is available and is posting the errors to the web page.

Are the Tmp006 sensitive to heat whilst soldering and if so how else can i connect these boards together?
In the last photo I am trying to place the temp sensor facedown (pointing through the enclosure) with the 8266 above it and slightly askew due to the space limitations. The sensor is receiving 3 volts and there appears to be no shorting on any of the pins.
IMG_9919.JPG
IMG_9919.JPG (86.18 KiB) Viewed 209 times
Attachments
IMG_9912.JPG
IMG_9912.JPG (103.85 KiB) Viewed 209 times

adoran
 
Posts: 8
Joined: Tue Sep 05, 2017 11:09 am

Re: TMP007 Problem

by adafruit_support_mike on Wed Dec 13, 2017 5:21 am

The sensor shouldn't be sensitive to the kind of soldering temperatures necessary to connect pin header. It's exposed to a lot more in the reflow oven.

As a sanity check, do you have any other kind of microcontroller you can use to test the sensors?

adafruit_support_mike
 
Posts: 50680
Joined: Thu Feb 11, 2010 2:51 pm

Re: TMP007 Problem

by adoran on Wed Dec 13, 2017 7:41 am

I have RPis and multiple adafruit arduino devices. currently trying to test the components as they arrive - received 3 new tmp006 - two function okay - one is questionable which i have secured some small croc clips to test without soldering.
Thanks for reply- are you suggesting testing with other arduino modules?

Anthony

adoran
 
Posts: 8
Joined: Tue Sep 05, 2017 11:09 am

Re: TMP007 Problem

by adafruit_support_mike on Sat Dec 16, 2017 4:49 am

Yes. Try connecting to the TMP007 using an Arduino and see if you have any better luck there.

adafruit_support_mike
 
Posts: 50680
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.