0

USBtinyISP no longer programs EEPROM
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

USBtinyISP no longer programs EEPROM

by mjsadaway on Fri Apr 13, 2018 7:54 pm

We are continuing to have problems writing EEPROM. Since my previous (sadly unanswered) post, we have tried unsuccessfully to program AVR chips other than ATtiny84s, so I'm posting again under a broader subject line.

Here are the answers to all of the questions you ask in your "How to get help!" post:

FIRST: Are you using a USBtiny from a kit or from DIY? Make sure you mention that in your post

We are using two different USBtinys that we purchased as kits directly from Adafruit a few years ago.

SECOND: What OS and computer are you using?

Windows 10 Pro Version 1709 on three different computers.

THIRD: Which programming software are you using, and what chip?

AVRDUDE 6.3 (the latest version) with ATtiny84s, ATtiny85s, and ATmega328Ps. We have also tried AVRDUDE 5.10, which doesn't give error messages but doesn't program the EEPROM either. The USBtinyISP driver was downloaded from the Adafruit website and reinstalled according to instructions a few days ago.

FOURTH: Did the USBtinyISP ever work (even once) or is it your first time trying to talk to a chip

Both USBtinyISPs worked correctly for about 3 years and have been used to program hundreds of ATtiny84s.

FIFTH: Post screenshots (NOT copy&paste) of what is happening

eetest.png
eetest.png (63 KiB) Viewed 178 times

SIXTH: Post clear, in-focus, not-blurry, easy to see photos of the top and bottom of the kit. If the photos are blurry, unfocused, and difficult to see they will only make it harder to debug what is going on

We don't want to pry open and risk breaking the cases. The problem is clearly not due to soldering or assembly errors, so pictures would not be helpful.

Is it possible that a wretched Windows 10 update is responsible?

Has anyone else had similar problems?

What does the "expected 128, got -116" error message mean?

Do you have any suggestions of things to try?

mjsadaway
 
Posts: 9
Joined: Thu Jun 13, 2013 2:45 am

Re: USBtinyISP no longer programs EEPROM

by Russell 27 on Sat Apr 14, 2018 1:26 pm

Can you write an eeprom.hex directly with avrdude, not using avrdude.conf. Your device and driver should be fine or you wouldn't have gotten this far.

Change command line directory to path where eeprom.hex is located.
Then type> avrdude -c usbtiny -p attiny84 -U eeprom:w:[your_eeprom_name].hex

If this works okay, might be a problem with your config file.
Russell 27
 
Posts: 240
Joined: Thu Sep 12, 2013 3:59 pm

Re: USBtinyISP no longer programs EEPROM

by mjsadaway on Fri Apr 27, 2018 3:09 am

Russell,

Thanks for your reply.

The same error occurs if I try the command line you suggested, i.e., if I omit the -C option and let avrdude use the default config file.

In fact, I added the -C option to make sure avrdude was using the default config file, the one that comes with the Arduino IDE.

And to make sure the Arduino IDE files were not corrupted, I downloaded and reinstalled the IDE.

The error message "avrdude: error: usbtiny_send: (expected 128, got -116)" appears to be specific to the USBtinyISP.

Therefore, I suspect it originated in code written at Adafruit if not by Ladyada herself, so someone at Adafruit should at least be able to tell me what the heck it means.

Expected 128 what? Got -116 what?

Mike

mjsadaway
 
Posts: 9
Joined: Thu Jun 13, 2013 2:45 am

Please be positive and constructive with your questions and comments.