0

Gemma bootloader just red, not blinking
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Gemma bootloader just red, not blinking

by mike3d0g on Fri Dec 16, 2016 4:41 am

When I plug my Gemma into a USB 2 hub and reset it, the red LED comes on for about 2 seconds and then turns off. It doesn't blink and it doesn't appear to get dim. When I try to upload code to it I get:
avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)


Tools > Board = Adafruit Gemma 8MHz
Tools > Programmer = USBtinyISP

The hub is connect to my Mac's USB 3 port. I've tried a different USB 2 hub. I've tried a different USB cable.

I ordered another Gemma, same thing.

I ordered an Arduino Uno and loaded the "trinket loader" on it, then wired it to the Gemma (as described in "Introducing Trinket"), including attaching the reset pin. The sketch appears to work, but it doesn't change the Gemma's boot loader. The sketch outputs:
Type 'G' or hit BUTTON for next chip
Starting Program Mode [OK]

Reading signature:930B
Searching for image...
Found "blankfull.hex" for attiny85

Setting fuses Set Low Fuse to: F1 -> A000 Set High Fuse to: D5 -> A800 Set Ext Fuse to: 6 -> A400
Verifying fuses...
Low Fuse: 0xF1 is 0xF1
High Fuse: 0xD5 is 0xD5
Ext Fuse: 0x6 is 0x6


Setting fuses

Verifing flash...
Flash verified correctly!
Verifying fuses...

Fuses verified correctly!
*OK!*


I'm completely at a loss. Can you help?

mike3d0g
 
Posts: 10
Joined: Mon Mar 30, 2015 3:33 pm

Re: Gemma bootloader just red, not blinking

by franklin97355 on Fri Dec 16, 2016 11:14 pm

I'll see if anyone has a solution for you.

franklin97355
 
Posts: 20105
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Gemma bootloader just red, not blinking

by mike3d0g on Sat Dec 17, 2016 11:44 am

Here's another clue, but it's bad news.

I have two Trinkets and when I plugged them into my hub, they also didn't blink. That's when I decided the problem must be in the hub or cables. There's just no way this many are bad out of the box. (I've been using 2', 3', and 6' cables to test.)

I have a Charger Doctor I bought from Adafruit and I put it on the USB hub. It shows 5.18V. Have I been blowing up my Trinkets and Gemmas with this powered USB hub?

Is a powered USB hub deadly to these devices?

mike3d0g
 
Posts: 10
Joined: Mon Mar 30, 2015 3:33 pm

Re: Gemma bootloader just red, not blinking

by franklin97355 on Sat Dec 17, 2016 1:26 pm

5.18 volts is still within specs so that should not be a problem.

franklin97355
 
Posts: 20105
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Gemma bootloader just red, not blinking

by adafruit_support_rick on Tue Dec 20, 2016 10:44 am

You are probably using charge-only cables.

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Gemma bootloader just red, not blinking

by mike3d0g on Fri Dec 30, 2016 3:24 am

I've confirmed that I'm using a data cable, though it turns out I did have some charge-only cables in the mix and didn't realize it. (I didn't even realize charge-only cables existed.)

But my devices still boot red, then flicker once, then off in about 3 seconds.

I'm going to order a new 5V Trinket for one last try. I can't guess at all what's wrong with these devices. Could I return them to you? I don't even want my money back, I just want to know what's gone wrong and how to avoid this in the future.

mike3d0g
 
Posts: 10
Joined: Mon Mar 30, 2015 3:33 pm

Re: Gemma bootloader just red, not blinking

by adafruit_support_rick on Fri Dec 30, 2016 9:56 am

Let me know what happens with the new trinket.

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Gemma bootloader just red, not blinking

by mike3d0g on Wed Jan 04, 2017 7:56 pm

I got a new Trinket and it didn't work and then I found the real problem.

My powered hub, which works with my mouse, keyboard, phone, Arduino Uno, and Arduino Mega... does not work with the Gemma or Trinket. I tried a different hub and it worked... Not only with the new Trinket, but with all of the old Gemmas and Trinkets I had.

The reason I didn't catch this before, when I tried a different hub, was probably because I was using one of the charge-only cables when I swapped hubs.

I just can't imagine why this particular hub isn't working, but for the number of hours I spent on this I will never let it be my friend again.

FWIW, when the Gemma or Trinket is getting whatever it needs for a good bootload cycle, the red LED is full-on bright... significantly brighter than the green LED. When it wasn't working, it was about half the brightness of the green LED.

mike3d0g
 
Posts: 10
Joined: Mon Mar 30, 2015 3:33 pm

Re: Gemma bootloader just red, not blinking

by mike3d0g on Wed Jan 04, 2017 8:03 pm

Thanks for the assist on this. The charge-only cables tip was the key to finding the real problem.

mike3d0g
 
Posts: 10
Joined: Mon Mar 30, 2015 3:33 pm

Re: Gemma bootloader just red, not blinking

by adafruit_support_rick on Thu Jan 05, 2017 11:46 am

Wow - we see plenty of bad cables, but I haven't seen a hub fail that works otherwise. What kind of hub is it?

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Gemma bootloader just red, not blinking

by mike3d0g on Thu Jan 05, 2017 12:42 pm

Actually, I loved the form factor of this hub. KB, mouse, and phone charging/data ports on the back, top port for flash drives or Arduino... in theory. It might be just this hub, which is a couple of years old.

http://www.staples.com/Staples-4-Port-U ... uct_837531

As soon as I told my wife the problem was the hub she told me I better not take hers. Prescient, she is. My new hub arrives tomorrow. I'm anxious to rebuild my project with a Trinket.

FWIW, I wish you sold a Trinket-sized perfboard, or maybe even a proto-board.

LOL -- I just watched the Collin's Lab video on perfboards. Very funny (and helpful to me). Thank you!

mike3d0g
 
Posts: 10
Joined: Mon Mar 30, 2015 3:33 pm

Re: Gemma bootloader just red, not blinking

by adafruit_support_rick on Fri Jan 06, 2017 12:02 pm

Yeah, that looks like a nice travel hub. Did you try all the ports with the gemma?

Wow - a trinket proto board. Now that would be small! I wonder if you could lay it out like a very small breadboard? Probably not enough room. But a simple perfboard could work...

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Gemma bootloader just red, not blinking

by mike3d0g on Fri Jan 20, 2017 3:21 pm

FWIW, my project was featured on https://www.hackster.io/mike3d0g/rgb-led-ugly-holiday-sweater-909bc4! It's a beginner's project, but the Ugly Holiday Sweater was very rewarding.

mike3d0g
 
Posts: 10
Joined: Mon Mar 30, 2015 3:33 pm

Re: Gemma bootloader just red, not blinking

by adafruit_support_rick on Sat Jan 21, 2017 4:38 am

Nice project! (Looks like my christmas tree... )

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Please be positive and constructive with your questions and comments.