0

Trouble uploading to Gemma
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Trouble uploading to Gemma

by drken on Mon Jul 31, 2017 6:26 pm

Trying to get sketches uploaded to an Adafruit Gemma (assume it 2.0, but I'm not sure how to tell). But I'm having issues:

Using Arduino 1.8.3 and OSX 10.12.5. Dowloaded the Adafruit board driver. Using USBTinyISP programmer. Hooked it up using a USB hub to avoid the USB 3.0 issue. Unlike with Uno and Nano, no new USB port shows up for the Gemma, so I use /dev.cu/Bluetooth-Incoming-Port (the only one that shows up). Press the button and get the pulsing red light. Then, when I try to upload "blink" I get a error
message: "avrdude: error: usbtiny_transmit: Device not configured".

There's also another whole bunch of error messages that read :

avrdude: error: usbtiny_receive: Result too large (expected 4, got -34)

avrdude: error: usbtiny_send: Device not configured (expected 64, got -6)

avrdude: error: usbtiny_receive: Device not configured (expected 4, got -6)

and so on...
"

Then the red light stays on for a second, then starts pulsing faster. Oddly, I get the same results if I try the Arduino Gemma Driver. I've tried everything I can find on the Internet, how can I get a Gemma to work with my MacBook Air?

drken
 
Posts: 7
Joined: Mon Jul 31, 2017 6:06 pm

Re: Trouble uploading to Gemma

by drken on Wed Aug 02, 2017 5:23 pm

I also get this at the end of the error message.

avr_read(): error reading address 0x0000
read operation not supported for memory "flash"
avrdude: failed to read all of flash memory, rc=-2

avrdude: error: usbtiny_transmit: Device not configured
avrdude: error: usbtiny_transmit: Device not configured


Also: Here is the Gemma portion of the boards.txt file.

# Gemma Configuration
gemma.name=Adafruit Gemma 8MHz
gemma.bootloader.low_fuses=0xF1
gemma.bootloader.high_fuses=0xD5
gemma.bootloader.extended_fuses=0xFE
gemma.bootloader.tool=arduino:avrdude
gemma.build.mcu=attiny85
gemma.build.f_cpu=8000000L
gemma.build.core=arduino:arduino
gemma.build.variant=tiny8
gemma.build.board=AVR_GEMMA
gemma.upload.tool=arduino:avrdude
gemma.upload.maximum_size=5310


Is there anything I should change to get it to work?

drken
 
Posts: 7
Joined: Mon Jul 31, 2017 6:06 pm

Please be positive and constructive with your questions and comments.