0

AVRDUDE
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

AVRDUDE

by shmagoogin77 on Mon Oct 01, 2007 10:02 pm

I downloaded ladyada's version of AVRDUDE from http://www.ladyada.net/make/usbtinyisp/download.html
and when i entered the commands -c usbtiny... is says cant find programmer id usbtiny
any help here???
by the way I am trying to program an arduino with this and would like step by step help with these if possible
shmagoogin77
 
Posts: 30
Joined: Mon Oct 01, 2007 9:58 pm

by adafruit on Mon Oct 01, 2007 10:09 pm

you probably didnt replace the old version thats why. do a search on your computer and make sure you replace the old avrdude and avrdude.conf

adafruit
 
Posts: 12149
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by shmagoogin77 on Tue Oct 02, 2007 5:39 pm

thanks for the help but now i am getting this
Code: Select all | TOGGLE FULL SIZE
avrdude -c usbtiny -p m168 -B 25
found 2 busses
Could not find USB device 0x1781/0xc9f

avrdude done.  Thank you.
shmagoogin77
 
Posts: 30
Joined: Mon Oct 01, 2007 9:58 pm

by adafruit on Tue Oct 02, 2007 6:02 pm

unplug and replug the device. does the green light near the USB jack turn on?

adafruit
 
Posts: 12149
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by shmagoogin77 on Tue Oct 02, 2007 6:03 pm

ya the green lights on i dont know what else to do
shmagoogin77
 
Posts: 30
Joined: Mon Oct 01, 2007 9:58 pm

by adafruit on Tue Oct 02, 2007 6:23 pm


adafruit
 
Posts: 12149
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by shmagoogin77 on Tue Oct 02, 2007 6:32 pm

i installed it and i tried reinstalling it twice, still nothing
does this mean its i built the circuit wrong?
shmagoogin77
 
Posts: 30
Joined: Mon Oct 01, 2007 9:58 pm

by adafruit on Tue Oct 02, 2007 8:39 pm

does the device show up in the Device Manager?
try a different USB port, if you have multiple ones.

adafruit
 
Posts: 12149
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by shmagoogin77 on Tue Oct 02, 2007 8:50 pm

ya the usbtiny shows up under device manager and iv tried switching ports
i need some serious help
shmagoogin77
 
Posts: 30
Joined: Mon Oct 01, 2007 9:58 pm

by adafruit on Tue Oct 02, 2007 9:57 pm

its probably a libusb dll conflict.

in the usbtinyisp driver zip file there is a file called libusb0.dll
copy this into the same directory where avrdude.exe is
if that doesnt help
look in C:/winxp/system32 for a file called libusb0.dll or similar. make a backup of it (rename it oldlibusb.dll or something) and then copy libusb0.dll into there too.

adafruit
 
Posts: 12149
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by shmagoogin77 on Tue Oct 02, 2007 10:06 pm

yaaa!!!
thanks ladyada it was the libusb0 problem
by the way with the usbtinyisp kit I received an extra PCB do you want it back?
shmagoogin77
 
Posts: 30
Joined: Mon Oct 01, 2007 9:58 pm

by adafruit on Tue Oct 02, 2007 10:50 pm

nah you can keep it. i have new a PCB version anyways so i couldnt use it.

adafruit
 
Posts: 12149
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Please be positive and constructive with your questions and comments.