0

ProTrinket Problems
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: ProTrinket Problems

by diggs on Mon Aug 22, 2016 12:25 pm

adafruit2 wrote:Hiya, we did all our development/testing (about 3 months worth) on windows 7 x64 so we dont think its a native win7 issue. We're always listening to customer support/refunds/returns for fairly new products to see if there's issues. So we are keeping an eye on this!

Each Pro Trinket is checked for enumeration during test, but it may be a computer/os/cable combination issue. If you are not able to get your Pro Trinkets going, email support@adafruit and they'll refund your order

If your compile time is longer than the bootloader timeout, click upload then press the reset button after a second or two

Alternatively, you can always use an FTDI Friend/Cable to upload! The bootloader will autodetect FTDI uploads and FTDI uploads will autoreset right before uploading, like an Uno :)

Hope that helps!


I found this post via internet search after experiencing the exact same issue with a new Pro Trinket 3V on 64-bit Windows 10. I was initially able to upload the Blink sketch without issue, but all subsequent uploads returned the rc=-1 error. Switching from a USB 3.0 to self-powered USB 2.0 hub did not make a difference. However, pressing the reset button right after the upload starts so far allows the upload to complete every time without fail. Just wanted to chime in to indicate that this issue exists on Windows 10 as well, but the reset solution does work.

diggs
 
Posts: 1
Joined: Mon Aug 22, 2016 11:56 am

Re: ProTrinket Problems

by netless on Mon Nov 05, 2018 6:21 am

OK I now have the same problem. I have been programming a ProTrinket for a couple of months to monitor & record temperatures from a digital probe - This is a reasonably complex code that uses most of the capacity of the ProTrinket. All has been working well until suddenly I started to receive upload verification errors. Sometimes my code will compile & upload OK, but mostly I'm getting verification errors uploading using an FTDI cable.

Wondering if this may be a problem with the USB on my Win10 desktop, I decided to swap to my Win10 Laptop & see if I could get Blink working.

The laptop does not recognize the FTDI connection at all - no sign of USBtiny in the Device Manager - just the following error from Arduino
***************************************************************************************************************
avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)
***************************************************************************************************************
If I swap back to a simple USB cable, USBtiny does appear in Device Manager & I can upload Blink - But only if I carefully time a reset, as described in the many posts above.

If I don't get the reset timing correct - I get the following upload error [still simple USB cable]
**********************************************************************************************************************
avrdude: error: usbtiny_transmit: libusb0-dll:err [control_msg] sending control message failed, win error: A device attached to the system is not functioning.
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.
avrdude: error: usbtiny_transmit: libusb0-dll:err [control_msg] sending control message failed, win error: A device attached to the system is not functioning.
the selected serial port
does not exist or your board is not connected
*********************************************************************************************************************
So at the moment I appear to have a partially functioning ProTrinket, but even then only on simple USB and not the FTDI connection that I need fora Serial connection.

Can anyone help so that I can get my project back on track? Is there a problem with my ProTrinket? Hardware? Software - Bootloader? My FTDI cable - though this still works on the Win10 desktop - that is when I don't get verification errors during the upload.

Any solutions will be much appreciated.

netless
 
Posts: 9
Joined: Sat Sep 22, 2018 4:20 am

Re: ProTrinket Problems

by netless on Mon Nov 05, 2018 7:58 am

Self Solution for Dumb Brain Fade

Changed the Laptop to ProTrinet(FTDI) :-) :-)

So FTDI all working well on my Laptop.

Still not sure what the upload verification error issue is on my Desktop - Maybe it is a flaky USB issue on the Desktop.

netless
 
Posts: 9
Joined: Sat Sep 22, 2018 4:20 am

Please be positive and constructive with your questions and comments.