0

avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by franklin97355 on Sun Mar 15, 2015 10:34 pm

I agree, this is really frustrating. Hours wasted... no success.
Could you provide more detail so that I may be able to help?

franklin97355
 
Posts: 21312
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by annie_z on Sat Aug 22, 2015 4:34 pm

Is there a driver version available for Windows 10?

annie_z
 
Posts: 2
Joined: Sat Aug 22, 2015 4:33 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by franklin97355 on Sat Aug 22, 2015 6:31 pm

Is there a driver version available for Windows 10?
A driver for what?

franklin97355
 
Posts: 21312
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by annie_z on Mon Aug 24, 2015 7:48 am

The original question was "A driver fir USBtiny for Windows 10." I tried the driver for Windows 8 and it works just fine.

annie_z
 
Posts: 2
Joined: Sat Aug 22, 2015 4:33 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by samuelguyer on Mon Aug 31, 2015 11:38 am

I'm currently seeing this error when trying to upload a sketch to a 3V Pro Trinket. I'm running version 1.6.5 of the Arduino IDE on a Mac (OSX 10.9.5). I have the Adafruit boards loaded into the IDE and I'm choosing the 3V Pro Trinket and USBtinyISP for the programmer. I've plugged and unplugged, restarted, etc. No luck. What is particularly frustrating is that when I open up the System Information app, it shows a USBtiny device with the correct product and vendor ID.

samuelguyer
 
Posts: 34
Joined: Mon Sep 02, 2013 12:38 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by stephenhow on Sun Oct 18, 2015 2:05 pm

I ran into this problem, where I got the "Could not find USBTiny device (0x1781/0xC9f)" message. Of course, it was my fault. I got the Blink example to load correctly through the FTDI Friend on my Mac OS X Yosemite running the Arduino 1.6.5 IDE by following https://learn.adafruit.com/introducing- ... using-ftdi

(I installed the FTDI VCP drivers from http://www.ftdichip.com/Drivers/VCP.htm)
selected Tools>Board>Pro Trinket (FDTI) [note: select the FTDI and not the USB version]
selected Tools>Port>"/dev/cu.usbserial-AH0331XQ"
selected Tools>Programmer>USBtinyISP

But, I noticed I have to power cycle the Trinket before each upload.

stephenhow
 
Posts: 2
Joined: Wed Oct 14, 2015 2:38 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by samuelguyer on Sun Oct 18, 2015 3:23 pm

That worked! Thank you!

I guess I got spoiled working on a Mac, where I rarely ever have to futz with drivers.

samuelguyer
 
Posts: 34
Joined: Mon Sep 02, 2013 12:38 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by MV702 on Fri Sep 02, 2016 4:55 pm

I too purchased the goggle kit and continue to get the "(0x1781/0xc9f)" error. I've tried every USB port on my PC and every micro USB cable I have, I've uninstalled and reinstalled all of the software. I've tried using both the 8Mhz and 16Mhz options, and I am using the USBtinyISP. Ideally, I'd like to have these up and running in a few days, if anyone knows why this still isn't working.

MV702
 
Posts: 1
Joined: Fri Sep 02, 2016 4:51 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by franklin97355 on Fri Sep 02, 2016 6:31 pm

Post pictures of your connections and soldering so we can take a look. Also post the entire error log.

franklin97355
 
Posts: 21312
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by libertyjwilson on Fri Sep 30, 2016 12:58 pm

Hi! Had this problem, and eventually figured out that I didn't have the driver installed

Try this: https://learn.adafruit.com/usbtinyisp/drivers

libertyjwilson
 
Posts: 1
Joined: Fri Sep 30, 2016 12:57 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by flashstick on Sat Oct 08, 2016 5:54 pm

I have a pro trinket 5v that isn't showing up on my El Capitan Mac no matter what I do.

I tried a usb 2.0 hub after seeing some reports that it doesn't work with 3.0 usb hubs, no success.

I tried resetting the bootloader with another board, no success.
I got the error:
Reading signature:FFFF
Searching for image...
Not Found
Image fail

when I tried to run it.
Granted I'm running it on a mega and not an uno because that's all I have right now, butI changed the pin definitions to the corresponding mega hardware spi pins so they should work.

Does anyone have an idea of what I can do differently?

flashstick
 
Posts: 17
Joined: Mon Nov 30, 2015 6:47 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by flashstick on Sun Oct 09, 2016 12:55 pm

Update: I got ahold of an uno and ran the program.
Same error as before except the signature it read is 200 rather than FFFF.

flashstick
 
Posts: 17
Joined: Mon Nov 30, 2015 6:47 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by burpees_NH on Mon May 28, 2018 6:43 pm

Hi. I ran into this exact error message today, and have a different and simple solution to offer:

Try another USB cable - use one with a ferrite bead, or "choke".

Some context:
I'm on OSX 10.13.4, using Arduino 1.8.5, and Adafruit Gemma (v2, the black one with a switch).
Note the USB cable that didn't work, is perfectly fine for other hardware and for charging -- but it wouldn't work with the Gemma (which has a built-in USBtiny programmer).

Both cables I tried are regular USB 2 cables, but I assume the choke helped with signal stability. I couldn't find my USB hub, lol.

burpees_NH
 
Posts: 69
Joined: Wed Dec 15, 2010 5:31 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by Phil_S on Tue Jul 31, 2018 7:19 pm

I have spent hours on this trying to upload blink.
This is a brand new Trinket 5-V from RS (UK).
In Win 10 Pro Settings>Devices, the Trinket shows with no driver available. In Control Panel, Trinket properties came up with no driver available.
Despite seeing somewhere in the Adafruit tutorial for Trinket suggesting that Win 10 might not need drivers to be installed.
Attempts to install a driver via the tutorial driver download link, Win came up with permission denied, Norton blocked it as unsafe. The ZIP version failed as well.
However, the link provided by Mr Wilson above (2016) worked a treat, and the upload was successful.
Thank you Sir, you are a gentleman and a scholar

Phil_S
 
Posts: 1
Joined: Fri Feb 13, 2015 1:29 pm

Re: avrdude: Error: Could not find USBtiny device (0x1781/0x

by royjackson419 on Tue Sep 04, 2018 4:31 pm

Gemma M0 USB Devices.JPG
Gemma M0 USB Devices.JPG (15 KiB) Viewed 2925 times
arduino ide gemma.png
arduino ide gemma.png (107.06 KiB) Viewed 2925 times
gemma m0 driver properties.JPG
gemma m0 driver properties.JPG (69.24 KiB) Viewed 2925 times



I am experiencing this very frustrating error as well. I am using windows 10, with black gemma and latest arduino IDE. I have tried this from scratch on windows 10 -2 machines now.

I have installed the drivers here:

https://learn.adafruit.com/usbtinyisp/drivers

I have done this several times, in the latest try I have removed all folders from here:

C:\Users\Roy\AppData\Local\Temp\adafruit_drivers\Drivers\

except for USBtinyISP. Previously I had installed all the drivers.

When I have my Gemma connected through a $35 USB 2.0 hub I bought to try to fix this problem, it doesn't produce a different result than when using my USB 3 plugs.

The result - running avrdude -c usbtiny -p m8

I have the error: avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)

Within arduino IDE I have installed the adafruit boards via the additional URL.

I have configured the boards, programmer, and tried differnet ports when options appear. Same error when trying to upload as with avrdude.

I can get the gemma into bootloader mode by pressing the button 2x in succession, where the light is solid green on 1 side, pulsating red on the other. My computer makes a sound, recognizes the device, but not as a USBTiny device.

When I try to remove / reinstall the device via device manager, the closest I can get is where libusb-win32 devices has multiple instances saying Gemma M0. It will not ever say USBTiny which is the desired result? When I try to set the device driver to the USBTiny dll provided by adafruit, windows tells me the driver is already up to date.

Please help! About 2 days of trial and error for sons bday project.

royjackson419
 
Posts: 5
Joined: Sun Sep 02, 2018 8:33 pm

Please be positive and constructive with your questions and comments.