Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.

Gemma bootloader
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Gemma bootloader

by jcmarr on Tue May 17, 2016 10:21 pm

Hi everyone,

First off, I love your website and products. With your help, I have gotten affordable materials for
students at a small, rural school district in the state of Washington. If anybody is interested,
I do pay for all these materials myself. That means that I need to make sure those materials
are both cost effective, and usable.

My trinket, and my Gemma both require several resets to activate the bootloader.

The Gemma is the big issue, I click the button over and over, looking for that bright, blinking, red light*. And then I panic,
and click the upload program button. 10 seconds is a long time, unless you have panicked.

I have tried several USB cables, all of which work to program a raspberry pi, and an arduino. After sifting through
several of the documents and talks available on your website, I am thinking that an investment in a USB 2 hub would
be the solution. Is this correct? Is the flaw in the USB cable? Is the flaw that my computer might have a USB 3 connection,
and how do I know which USB port is powered?

To summarize:
1. Does the USB port need to be a USB 2?
2. How do I check a USB cable? If it is good for most communications, is it good for everything?
3. Am I missing any Mac issues?

Posts: 1
Joined: Tue May 17, 2016 10:03 pm

Re: Gemma bootloader

by adafruit_support_rick on Fri May 20, 2016 3:28 pm

Once you get the pulsing red light, does the upload succeed?

Does the red light blink at all when you *don't* get the pulsing? If so, your USB setup is likely at fault. The Gemma bootloader will blink the red light if it doesn't have a good USB connection. Have you tried different USB ports on your Mac? USB3 ports do work, but we see problems with them on occasion.

Since you have the same problem on both a trinket and a gemma, it's not likely to be the trinket or gemma at fault. Do you have access to another computer you can try?

I'm not sure a USB hub will cure the problem, but it might be worth a try, if you can afford it. Can you borrow one for testing?

Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Please be positive and constructive with your questions and comments.