0

Serial usbmodem port stopped working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Serial usbmodem port stopped working

by odonovanpm on Sat Aug 27, 2016 10:45 am

I undertook the Arduino IDE setup and library installations as per the instructions in the FLORA starter pack. After following all of the instructions I successfully loaded a sketch on the board to flash the LED. However, at some point the serial port disappeared from Arduino, which prevents the uploading of new sketches. The USB does not appear to be listed in my connected devices, however, the FLORA board is still being powered through the USB cable (i.e. LED is blinking as per the original sketch). I tried to change USB cables, and ran Arduino on both Mac and Windows OS's.

Although I am new to wearables, I feel the board is in some way faulty. When I requested a return, customer service suggested posting the issue here before returning the starter pack.

odonovanpm
 
Posts: 6
Joined: Sat Aug 27, 2016 10:39 am

Re: Serial usbmodem port stopped working

by adafruit_support_rick on Sun Aug 28, 2016 9:55 am

What happens when you press the reset button? Does the red LED begin to fade in and out?
If that doesn't happen, you may have to 'double-click' the reset button.

Also, try the reset procedure outlined here:
https://learn.adafruit.com/adafruit-fea ... /faq#faq-2

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Serial usbmodem port stopped working

by odonovanpm on Mon Aug 29, 2016 8:43 am

When I click the reset button the red LED phases in/out as described. However, the reset option did not fix the issue (see attached).

The frustrating thing is that I was able to see the port, and upload a sketch previously. I connected the accelerometer with alligator clips and reconnected the board and the serial port was gone.
Attachments
Screenshot 2016-08-29 13.41.24.png
Screenshot 2016-08-29 13.41.24.png (345.15 KiB) Viewed 770 times

odonovanpm
 
Posts: 6
Joined: Sat Aug 27, 2016 10:39 am

Re: Serial usbmodem port stopped working

by adafruit_support_rick on Mon Aug 29, 2016 8:54 am

You probably have a bad USB cable. If the red LED is pulsing, then the bootloader is working. Try some different cables, try some different ports, try a USB2.0 hub

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Serial usbmodem port stopped working

by odonovanpm on Mon Aug 29, 2016 9:45 am

I tried multiple USB cables, on multiple computers including the one provided in the kit. More importantly, why would it stop working after an hour?

odonovanpm
 
Posts: 6
Joined: Sat Aug 27, 2016 10:39 am

Re: Serial usbmodem port stopped working

by adafruit_support_rick on Mon Aug 29, 2016 2:10 pm

Well, I don't know. We can replace the flora. Please email support@adafruit.com with a link to this thread for a replacement

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Serial usbmodem port stopped working

by odonovanpm on Mon Aug 29, 2016 3:18 pm

I have requested a replacement unit from customer support. There definitely appears to be an issue with the USB interface - when I connected the board to another MS Windows PC (after installing Arduino and board drivers I received another error (attached).
Attachments
Capture.PNG
Capture.PNG (9.45 KiB) Viewed 749 times

odonovanpm
 
Posts: 6
Joined: Sat Aug 27, 2016 10:39 am

Re: Serial usbmodem port stopped working

by adafruit2 on Tue Sep 06, 2016 1:55 pm

you had the Bluetooth serial port selected up above - you need to fix that to the right FLORA USB port :)

adafruit2
Site Admin
 
Posts: 18327
Joined: Fri Mar 11, 2005 7:36 pm

Re: Serial usbmodem port stopped working

by odonovanpm on Tue Sep 06, 2016 2:14 pm

Apologies, but I do not follow your reference - the problem is that I cannot the FLORA USB port is not visible in the Arduino IDE.

odonovanpm
 
Posts: 6
Joined: Sat Aug 27, 2016 10:39 am

Re: Serial usbmodem port stopped working

by zgurga2295 on Tue Oct 11, 2016 4:53 pm

Please help as soon as possible,

I am using my Arduino Uno board on my mac, and when I first downloaded the software and hooked up the Arduino Board to my computer, I was successful. I am trying again and my port is missing it was a usbmoden1142 port and when I look in the tool bar, the only available ports are the bluetooth ports. Why would my port have gone missing? How can I get the port back? I tried using the bluetooth ports but they won't run my programs.

zgurga2295
 
Posts: 4
Joined: Tue Oct 11, 2016 4:50 pm

Re: Serial usbmodem port stopped working

by odonovanpm on Wed Oct 12, 2016 3:19 am

I received a replacement board and it worked fine. Therefore, it would appear my board entered a faulty state.

odonovanpm
 
Posts: 6
Joined: Sat Aug 27, 2016 10:39 am

Re: Serial usbmodem port stopped working

by adafruit_support_rick on Wed Oct 12, 2016 10:26 am

zgurga2295 wrote:Please help as soon as possible,

I am using my Arduino Uno board on my mac, and when I first downloaded the software and hooked up the Arduino Board to my computer, I was successful. I am trying again and my port is missing it was a usbmoden1142 port and when I look in the tool bar, the only available ports are the bluetooth ports. Why would my port have gone missing? How can I get the port back? I tried using the bluetooth ports but they won't run my programs.


Have you tried some different USB cables? Also try a different USB port on your computer. You can also try a USB 2.0 hub.

Also, try rebooting your Mac.

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Serial usbmodem port stopped working

by zgurga2295 on Thu Oct 13, 2016 9:55 am

I tried rebooting my mac, using another usb port and another usb cable. Still not able to find the port. I tried hooking it up to a windows computer and was still unlucky in getting the Arduino board to run, the other computer was not able to find any ports. Do you think it is a faulty board?

zgurga2295
 
Posts: 4
Joined: Tue Oct 11, 2016 4:50 pm

Re: Serial usbmodem port stopped working

by adafruit_support_rick on Thu Oct 13, 2016 10:35 am

Sounds like the Serial-USB chip got corrupter somehow or failed. Please email support@adafruit.com with a link to this thread for a replacement Uno

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Please be positive and constructive with your questions and comments.