0

boot problem?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

boot problem?

by vborgese on Thu Sep 08, 2016 8:55 pm

sorry newbie question here. raspberry pi 2 starter kit bought new from adafruit in dec 2015. tried to use it first time today. green led flashes 4 times, so in reading a few other posts, seems it cant find the files on the SD card to boot. the leds consistently blink 4 times, whether the card is in or not. card is labeled raspbian wheezy. put the card in a PC and can see files, no problem. card does seem to "stick" or not go in all the way sometimes. can get it to go in all the way however. and then releases ok too.

vborgese
 
Posts: 3
Joined: Thu Sep 08, 2016 8:34 pm

Re: boot problem?

by adafruit_support_mike on Fri Sep 09, 2016 12:12 am

When you say you can see the files on a desktop computer, do you see a single directory that contains about two dozen config files (one named 'config.txt'), or do you see a whole file tree with directory names like 'etc', 'usr', and so on?

adafruit_support_mike
 
Posts: 55974
Joined: Thu Feb 11, 2010 2:51 pm

Re: boot problem?

by vborgese on Sun Sep 11, 2016 8:16 am

The former. I see about 2 dozen files one of them being config.Txt start, another being start.elf.

vborgese
 
Posts: 3
Joined: Thu Sep 08, 2016 8:34 pm

Re: boot problem?

by adafruit_support_mike on Sun Sep 11, 2016 11:07 pm

Okay, that suggests the OS image has been written properly.

You might want to try an SD card with a fresh OS image downloaded from the RasPi Foundation:

https://www.raspberrypi.org/downloads/raspbian/

If that doesn't work, it may be a hardware problem in the RasPi. Unfortunately, you're way past our 30 day return/replace period, and we have to be strict about that. It's too easy for someone to kill a piece of hardware and say, "I just took it out of the bag today ..."

adafruit_support_mike
 
Posts: 55974
Joined: Thu Feb 11, 2010 2:51 pm

Re: boot problem?

by vborgese on Tue Sep 13, 2016 7:34 pm

Well we did just try it a few days ago for the first time. I attached a pic of all the other starter kit items still in their original wrapping.

If it is a hardware problem with the SD card slot, can it boot from a USB stick?

Vin
Attachments
2016-09-13 19.27.12.png
2016-09-13 19.27.12.png (105.84 KiB) Viewed 571 times

vborgese
 
Posts: 3
Joined: Thu Sep 08, 2016 8:34 pm

Re: boot problem?

by adafruit_support_mike on Tue Sep 13, 2016 11:57 pm

Unfortunately, we have to deal with a steady stream of people who think they can break hardware and say, "I just took it out of the box and it doesn't work" to get free replacements. They're the ones who complain loudest if someone else gets a break that they don't, so to keep them under control, we have to say no to everyone.

Going forward, remember that it's important to check hardware when you receive it. We can afford to be much more relaxed about replacements the day after a package arrives than we can be nine months later.


WRT booting the RasPi from a USB stick, that still requires an SD card. The microcontroller that starts things going is hardwired to load the bootloader executable off the SD card.

Try some other SD cards, and try the latest version of Raspbian. The 4-flash pattern means the bootloader was found, but couldn't be executed. That suggests basic communication with the SD card might be working.

adafruit_support_mike
 
Posts: 55974
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.