0

Newbie here can't get first upload from tutorial to work!
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Newbie here can't get first upload from tutorial to work!

by imvain2 on Wed Oct 03, 2007 9:56 pm

I have followed the tutorial installation steps however when I get to the upload part I get the below error:

ser_send(): write error: sorry no info avail
imvain2
 
Posts: 7
Joined: Wed Oct 03, 2007 9:53 pm

by adafruit on Wed Oct 03, 2007 9:56 pm

you need to post more information
what computer
what OS
what version of arduino
etc.

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by imvain2 on Wed Oct 03, 2007 10:05 pm

Windows XP
Dell 3000
Decimilia

I reselected the correct com port, now get a new error:

can't open device "COM17": The system cannot find the file specified
imvain2
 
Posts: 7
Joined: Wed Oct 03, 2007 9:53 pm

by imvain2 on Wed Oct 03, 2007 10:16 pm

I saw this issue with avrdude and the irobot:

http://createforums.irobot.com/irobotcr ... age.id=415

I have tried plugging into other USB ports, and refreshing the device manager but still com17.
imvain2
 
Posts: 7
Joined: Wed Oct 03, 2007 9:53 pm

by adafruit on Wed Oct 03, 2007 10:20 pm

you cant use com ports higher than 10, although the error message is bad.
use the device manager (right click on the usb device->properties->port settings->advanced) to set the port to something like COM3 or whatever.

ignore it if it says the port is already in use.

try a few different ones (COM ports) until it works.

alternately, use FTClean (google for it) to remove the 16 other comports

ive asked the arduino team to fix this problem and give a more useful error message but...

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by imvain2 on Wed Oct 03, 2007 11:02 pm

Great it works.

Thanks
imvain2
 
Posts: 7
Joined: Wed Oct 03, 2007 9:53 pm

by adafruit on Wed Oct 03, 2007 11:08 pm

cool
ive added your problems to my HELP document
http://www.ladyada.net/learn/arduino/help.html
hopefully soon it will have 'nearly eveything' :)

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

by imvain2 on Wed Oct 03, 2007 11:10 pm

After I go back through the lessons, I realized that it does show this problem and the solution. So I should of just continued reading.
imvain2
 
Posts: 7
Joined: Wed Oct 03, 2007 9:53 pm

by adafruit on Wed Oct 03, 2007 11:12 pm

nope. i just added it :)

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Please be positive and constructive with your questions and comments.