0

BLE nRF8001 - TOTAL_PORTS error
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

BLE nRF8001 - TOTAL_PORTS error

by frenky_red on Sun Jan 10, 2016 12:03 pm

Hi everybody,

My friend and me are quite newbie in the Arduino world, recently we've been tinkering around and after having done the first steps with LED and so on we wanted to try the BLE connectivity. It looked like straight forward but something went wrong on the way.
We have a nano Arduino connected with a BLE module nRF8001, and we have followed the all step indicated at the link:
https://learn.adafruit.com/getting-star ... troduction
We managed with the first part of the tutorial, the callbackEcho example, we could easily send and check the text sent through the official app. After that we wanted to try the Pin I/O options with the StandardFirmata example and somehow the code doesn’t compile with giving back this error message.
Code issue.jpg
Code issue.jpg (507.77 KiB) Viewed 1393 times


Any advice on what we have might missed to do and did wrong ?

Thanks in advance for the help.
J&F

frenky_red
 
Posts: 2
Joined: Sun Jan 10, 2016 11:57 am

Re: BLE nRF8001 - TOTAL_PORTS error

by adafruit_support_mike on Mon Jan 11, 2016 4:19 am

Hmm.. that looks like something amiss in the Firmata library. Let me check with the folks who maintain that code.

adafruit_support_mike
 
Posts: 63059
Joined: Thu Feb 11, 2010 2:51 pm

Re: BLE nRF8001 - TOTAL_PORTS error

by frenky_red on Mon Jan 11, 2016 8:26 am

Thanks!

We thought something was wrong with the library but we don't have enough experience about it and it became quite difficult.
We will wait for some news.

Thanks in advance.
Frenky

frenky_red
 
Posts: 2
Joined: Sun Jan 10, 2016 11:57 am

Re: BLE nRF8001 - TOTAL_PORTS error

by collinmel on Mon Jan 11, 2016 3:36 pm

This issue is currently being worked on -
https://github.com/adafruit/Adafruit_BL ... -170395461

in the meantime you can manually install previous version of the Pin I/O code found here:
https://github.com/adafruit/Adafruit_BL ... dcc597f1d8

collinmel
 
Posts: 58
Joined: Thu Aug 07, 2008 12:16 pm

Re: BLE nRF8001 - TOTAL_PORTS error

by dadeyemi11 on Tue Feb 23, 2016 12:43 pm

I'm having that exact problem as well! Thanks for any help

dadeyemi11
 
Posts: 5
Joined: Tue Feb 23, 2016 12:32 pm

Re: BLE nRF8001 - TOTAL_PORTS error

by adafruit_support_mike on Thu Feb 25, 2016 11:54 pm

Installing the previous version of the library, as mentioned above, should do the trick.

adafruit_support_mike
 
Posts: 63059
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.