0

Wave shield not working?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Wave shield not working?

by Themagicmitch on Wed Jul 12, 2017 4:16 am

I recently finished building my waveshield for my uno. How ever after I thought I programmed it for the voice modifier I plugged in my speaker and noThing happened. There isn't even the feedback noise when entering headphones into the jack. I don't know if this is because I've soldered it wrong or if I hadn't programmed it right or if something is really wrong. Would love some help as this is my first audiino project.

Themagicmitch
 
Posts: 5
Joined: Wed Jul 12, 2017 4:03 am

Re: Wave shield not working?

by adafruit_support_bill on Wed Jul 12, 2017 6:43 am

Please post some photos of the front and back of the shield showing all your soldering and connections.

adafruit_support_bill
 
Posts: 60286
Joined: Sat Feb 07, 2009 10:11 am

Re: Wave shield not working?

by Themagicmitch on Wed Jul 12, 2017 7:00 am

Ok so I did some rewiring and now when I plug my headphones in I hear the feedback noise. But I still can't get and sound to come out. I am doing the voice modulator it might be the wrong code or something. Does anybody have any instructions on which code s to use

Themagicmitch
 
Posts: 5
Joined: Wed Jul 12, 2017 4:03 am

Re: Wave shield not working?

by adafruit_support_bill on Wed Jul 12, 2017 7:26 am

https://learn.adafruit.com/wave-shield-voice-changer/building-it#adding-voice-effects-and-a-sound-trigger-keypad

Use the adavoice sketch. There is a link in the guide to download the code for it: https://learn.adafruit.com/wave-shield- ... ger-keypad

adafruit_support_bill
 
Posts: 60286
Joined: Sat Feb 07, 2009 10:11 am

Re: Wave shield not working?

by Themagicmitch on Wed Jul 12, 2017 4:36 pm

I followed the instructions from that site and uploaded the code and still nothing. I also
Tried uploading photos of my wave shield but the file
Size is too big. Is there a email I can use?

Themagicmitch
 
Posts: 5
Joined: Wed Jul 12, 2017 4:03 am

Re: Wave shield not working?

by adafruit_support_bill on Wed Jul 12, 2017 4:47 pm

There is a 1 meg limit for uploads. If you resize your photos to 800x600 you should have no problems.

adafruit_support_bill
 
Posts: 60286
Joined: Sat Feb 07, 2009 10:11 am

Re: Wave shield not working?

by Themagicmitch on Sun Jul 16, 2017 6:02 pm

Thanks it's all working now and it's really good. Now the final thing I'm struggling with is I want to get rid of the breadboard. I have breadboarded out the potentiometer and the microphone. How can I get them off?

Themagicmitch
 
Posts: 5
Joined: Wed Jul 12, 2017 4:03 am

Re: Wave shield not working?

by adafruit_support_bill on Sun Jul 16, 2017 6:48 pm

You can use a proto-shield and move your breadboard circuits to that.

adafruit_support_bill
 
Posts: 60286
Joined: Sat Feb 07, 2009 10:11 am

Re: Wave shield not working?

by Themagicmitch on Tue Jul 18, 2017 6:22 pm

Hi, your help has been really helpful and it got my waveshield working and looking good. However today I tested my modulator and it didn't work. Instead I've got a noise. Almost like a heart beat coming out instead ye mic isn't picking up my voice and ye beating is in tune with a flash on the uno r3 I have rewired the mic several times and other parts and nothing seems to be working any ideas ?
Ps I haven't transferred on to the protoshield yet I was about to when I realised it had stopped working.

Themagicmitch
 
Posts: 5
Joined: Wed Jul 12, 2017 4:03 am

Re: Wave shield not working?

by adafruit_support_bill on Tue Jul 18, 2017 7:19 pm

The voice changer circuit is pretty sensitive to wiring issues. It is important to keep the microphone and speaker wiring separated to avoid feedback and interference. If you post some photos we can look for any potential problems there.

adafruit_support_bill
 
Posts: 60286
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.