0

Can't get Hallowing into bootlader mode
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Can't get Hallowing into bootlader mode

by lewandor on Sat Dec 29, 2018 7:01 pm

I was trying to get my Hallowing into bootloader mode by double tapping the reset button and as far as I can tell it's not going happening. None of the LEDs do anything different, and I don't see a drive show up on my computer. I can load various test programs on it via the Arduino IDE, so it seems to be working fine otherwise. Is there something I'm missing about how to get into bootloader mode?

Thanks!

lewandor
 
Posts: 9
Joined: Sat Oct 31, 2015 6:38 pm

Re: Can't get Hallowing into bootlader mode

by lewandor on Fri Jan 04, 2019 9:20 am

Anyone have any ideas about how to get my Hallowing into bootloader mode?

lewandor
 
Posts: 9
Joined: Sat Oct 31, 2015 6:38 pm

Re: Can't get Hallowing into bootlader mode

by adafruit_support_carter on Fri Jan 04, 2019 2:02 pm

There are some known issues that prevent the HALLOWBOOT folder from showing up:
https://learn.adafruit.com/welcome-to-c ... esent-19-4

But it's weird that you are not seeing anything on the LEDs. When in bootloader mode, the NeoPixel by the teeth should be green and the little red LED by the micro-USB should pulse.

adafruit_support_carter
 
Posts: 9729
Joined: Tue Nov 29, 2016 2:45 pm

Re: Can't get Hallowing into bootlader mode

by lewandor on Fri Jan 04, 2019 8:03 pm

The NeoPixel doesn't light up at all, and the red LED is solid.

I looked at your troubleshooting link. It looks like there are a couple things to try on a Windows machine, but I'm using a Mac. (I have also tried to get into the bootloader while connected to a Windows machine without luck).

lewandor
 
Posts: 9
Joined: Sat Oct 31, 2015 6:38 pm

Re: Can't get Hallowing into bootlader mode

by adafruit_support_carter on Fri Jan 04, 2019 8:21 pm

Weird. Are you sure you are actually still able to load Arduino programs? Try loading blink and changing the blink rate.

adafruit_support_carter
 
Posts: 9729
Joined: Tue Nov 29, 2016 2:45 pm

Re: Can't get Hallowing into bootlader mode

by lewandor on Sat Jan 05, 2019 2:14 pm

Blink test loads fine. Red LED blinks as expected. I am able to also change the blink rate. (I hadn't noticed before, but the NeoPixel lights up green during upload so it seems like that's at least partially functional.)
Graphics test code (https://learn.adafruit.com/adafruit-hal ... -code-8-17) also loads and runs fine.

I was mistaken earlier when I said the red LED was solid when I tried to go into Bootloader mode. It was actually the orange charging LED that was solid, and the RED LED remained off. Now that I have the blink code loaded, the LED continues to blink when I hit reset.

After some messing around with the blink code, I tried to upload the graphics test code again. This time it failed while writing. And, oddly, it went into bootloader mode: The NeoPixel is green, red LED is pulsing. And I also have a warning from my OS that "HALLOWBOOT" did not eject properly.

I hit reset again, and it appeared to start in bootloader mode. This time I could see the HALLOWBOOT disk, so I copied over the spooky eye UF2 and it worked. I tried to reset into bootloader mode again....and no luck. Uploaded graphics test. Worked. Blink: works. But I can't force it into bootloader mode.

lewandor
 
Posts: 9
Joined: Sat Oct 31, 2015 6:38 pm

Re: Can't get Hallowing into bootlader mode

by adafruit_support_carter on Mon Jan 07, 2019 2:05 pm

Do you have another computer you can try on? Also try other cables and USB ports to see if it behaves differently.

What version of Mac OS are you on?

adafruit_support_carter
 
Posts: 9729
Joined: Tue Nov 29, 2016 2:45 pm

Re: Can't get Hallowing into bootlader mode

by lewandor on Wed Jan 09, 2019 12:34 am

I've tried 3 different cables on the two USB ports of my Macbook Air running Sierra 10.12.6 and a Macbook Pro running High Sierra 10.13.6. I have tried on a PC, but I think I only tried one cable. Results have been the same.

lewandor
 
Posts: 9
Joined: Sat Oct 31, 2015 6:38 pm

Re: Can't get Hallowing into bootlader mode

by adafruit_support_carter on Wed Jan 09, 2019 12:38 pm

Since you were able to get it back into bootloader mode, but somewhat randomly, I was wondering if it might be marginal USB cable or port issues. Can you try whatever you did here again and see if you can get HALLOWBOOT to show up again?

After some messing around with the blink code, I tried to upload the graphics test code again. This time it failed while writing. And, oddly, it went into bootloader mode: The NeoPixel is green, red LED is pulsing. And I also have a warning from my OS that "HALLOWBOOT" did not eject properly.

adafruit_support_carter
 
Posts: 9729
Joined: Tue Nov 29, 2016 2:45 pm

Re: Can't get Hallowing into bootlader mode

by lewandor on Thu Jan 10, 2019 8:49 pm

I've tried the same things that put the board into bootloader more before. I've tried on two different Macbooks, 2 USB ports per Macbook, 3 cables per port. As far as I can tell, it doesn't appear to be a USB port, cable, or OS version issue. I'm about to just throw in the towel on this. I can only spend so much time cable swapping and uploading code just to get a device into bootloader mode. :) I thought I'd play with CircuitPython, but I think I'll pick up another device.

lewandor
 
Posts: 9
Joined: Sat Oct 31, 2015 6:38 pm

Re: Can't get Hallowing into bootlader mode

by adafruit_support_carter on Fri Jan 11, 2019 2:22 am

Really weird behavior. Let's try a replacement and see if that works any better. You can email support@adafruit.com with a link to this thread along with your order number and they can you get you a replacement Hallowing.

Please report back on how well the replacement one works.

adafruit_support_carter
 
Posts: 9729
Joined: Tue Nov 29, 2016 2:45 pm

Re: Can't get Hallowing into bootlader mode

by lewandor on Fri Jan 11, 2019 12:52 pm

Thanks. I'll send an email to support.

lewandor
 
Posts: 9
Joined: Sat Oct 31, 2015 6:38 pm

Re: Can't get Hallowing into bootlader mode

by adafruit_support_carter on Fri Jan 11, 2019 1:52 pm

Thanks. Let us now how it goes. Maybe you've discovered a new combination of OS / USB port / cable / software that's causing some oddness.

adafruit_support_carter
 
Posts: 9729
Joined: Tue Nov 29, 2016 2:45 pm

Re: Can't get Hallowing into bootlader mode

by lewandor on Sat Jan 19, 2019 1:45 pm

Just got my new Hallowing yesterday, and it works! Thanks for the support. I'm not sure what's wrong with the other one, but the new one behaves as expected so far.

lewandor
 
Posts: 9
Joined: Sat Oct 31, 2015 6:38 pm

Re: Can't get Hallowing into bootlader mode

by adafruit_support_carter on Mon Jan 21, 2019 2:40 pm

Glad the new one works. Thanks for letting us know. What's going on with the other one is a mystery to us also.

adafruit_support_carter
 
Posts: 9729
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.