0

12 bit PWM servo shield
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

12 bit PWM servo shield

by clemly on Wed Sep 22, 2021 11:41 pm

Hi. I'm having trouble with the PWM pins on the 12 bit PWM servo shield. None of the pins from PWM 0 to 13 seem to connect to the Arduino or even the shield's Digital I/O pins. I used a voltmeter to check the connections, and all PWM pins from 0 to 13 do not have an electrical connection to the Digital I/O pins. The adjacent GND pins and V+ pins all have an electrical connection. What's going on? I know it's not my soldering. I actually bought a second identical board to see if I have the same problem, and... I do!!!! Am I just misunderstanding this board, and I need to run jumper wires from the PWM pins to the Digital I/O pins? All the photos online do not seem to do this. Please help. Thank you.

clemly
 
Posts: 2
Joined: Wed Sep 22, 2021 11:36 pm

Re: 12 bit PWM servo shield

by franklin97355 on Thu Sep 23, 2021 12:45 am

The shield uses i2c to communicate with the Arduino so there should be no electrical connection. Take a look at this tutorial
https://learn.adafruit.com/adafruit-16-channel-pwm-slash-servo-shield/downloads-links
What are you using for the Arduino?

franklin97355
 
Posts: 22243
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: 12 bit PWM servo shield

by clemly on Mon Oct 04, 2021 8:53 pm

Ah hah! Thank you!!!!!

clemly
 
Posts: 2
Joined: Wed Sep 22, 2021 11:36 pm

Please be positive and constructive with your questions and comments.