0

Trellis M4 Connectivity
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Trellis M4 Connectivity

by eightlines on Thu Aug 15, 2019 6:04 pm

I recently purchased a Trellis M4 and I cannot connect it to my Mac Book Pro 2016 OS 10.14.3 (USB C ports only).

I've tried:
- Different USB B Micro - USB A cables,
- Different Multiport Adapters,
- USB C - USB A adapter.
- Reset the computer.
- Did a PRAM reset.
- Reinstalling the SAMD libraries. (I don't think the libs are required to make the device show up in /dev/)
- Double click the Reset button on the back of the circuit board and click it back to it's normal state.
- Gone through the tutorial several times.

The device does not appear in /dev/tty.* under any conditions.

My question, is there anything else I can do to attempt to communicate to the device through this computer? I have programmed SAMD chipsets before without issue. I will attempt to program it through a Windows or RPI machine next, but since this laptop is my primary device I'd prefer to code here. Suggestions appreciated.

eightlines
 
Posts: 15
Joined: Tue Nov 04, 2008 11:36 pm

Re: Trellis M4 Connectivity

by adafruit_support_mike on Sat Aug 17, 2019 12:53 am

First, verify your USB cables by using them to connect some other, known-working device to the computer.

There's a plague of charge-only cables out there with USB connectors at both ends, but no wires for the data signals. We see people get caught by them every day.

Just swapping cables has no diagnostic value.. it's become normal for people to say they had to try three or four cables before finding one that worked. You need the true positive of a working connection to rule out the false negative of a charge-only cable.

adafruit_support_mike
 
Posts: 58856
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.