0

Troubleshooting Adafruit Micro SD breakout board
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Troubleshooting Adafruit Micro SD breakout board

by AKarsay on Wed Aug 28, 2019 2:00 am

Hello, I recently purchased a MicroSD card breakout board from Adafruit and I am having a hard time using it. This is the first time that I have tried to use something like this and also the first time that I have soldered onto a board like this. That being said, I am not sure if I somehow messed something up when I did said soldering. All I have tried to do with it is run the CardInfo sketch after following the tutorial with no luck. I have the "SD.h" library installed and when I search for the "SPI.h" library it just shows the SD library I was not able to find it? I just assumed that it was maybe auto downloaded when I originally downloaded the Arduino IDE since the file complied with no errors. Also I did remember to change the CS pin to 10 since that was what the tutorial was using. Using 4 did not change the result. I am using an Arduino Uno with version 1.8.7 of the IDE. Any help or suggestions would be appreciated. :)
Attachments
SD_Soldering.jpg
SD_Soldering.jpg (877.05 KiB) Viewed 64 times
SD_Wiring.jpg
SD_Wiring.jpg (982.34 KiB) Viewed 64 times

AKarsay
 
Posts: 1
Joined: Wed Aug 28, 2019 1:28 am

Re: Troubleshooting Adafruit Micro SD breakout board

by dastels on Wed Sep 04, 2019 2:27 pm

Your solder joints look very suspect. Check the tutorial here https://learn.adafruit.com/collins-lab-soldering for a technique refresher. The solder joints is always the first thing I check and double check when there is a problem.

Dave

dastels
 
Posts: 203
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.