0

FX Sound Board random skips in audio output
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

FX Sound Board random skips in audio output

by jkandler on Wed Aug 28, 2019 5:19 pm

Loaded two small files. I can play the whole files from the sound board on my PC. Removed the USB cable. Connected the 3 AA battery pack, turned it on. Red led is ON. Connect an Amazon BlueTooth Speaker (BSK20) by Audio Cable Phone Jacks. Randomly the output of the play skips several seconds of playback. ??? Disconnect the speaker and plug into my computer, it plays without skipping. ??? Change audio cable to new one, still get random skips in the playback for the Sound Card.??? Plug in earbuds, it works!!! No skips. But now only one can hear, when many are intended to listen. What is going on???

jkandler
 
Posts: 6
Joined: Tue Aug 20, 2019 2:34 pm

Re: FX Sound Board random skips in audio output

by adafruit_support_carter on Wed Aug 28, 2019 7:27 pm

You're plugging these speakers into the headphone jack on the sound board? Are they self powered speakers?

adafruit_support_carter
 
Posts: 12991
Joined: Tue Nov 29, 2016 2:45 pm

Re: FX Sound Board random skips in audio output

by jkandler on Thu Aug 29, 2019 12:50 pm

Yes the Amazon BSK20 is self powered. That was the idea in the first place. To have the sound board play the sound and the speaker broadcast it for all to hear. Kind of like using an MP3 played into an amplified speaker. But disposed of MP3 players years ago.

New information. A Casio portable speaker was connected in place of the Amazon on the audio jack, and the broadcast does not skip!!! Wow, Is the the soundcard having a problem with the BSK20. It appears so, since also when the earbuds are connected it also works correctly, as it did when connected by only USB to my computer, played to file off the sound card.

jkandler
 
Posts: 6
Joined: Tue Aug 20, 2019 2:34 pm

Re: FX Sound Board random skips in audio output

by adafruit_support_carter on Thu Aug 29, 2019 1:00 pm

Can you link to the Amazon product page for these speakers.

adafruit_support_carter
 
Posts: 12991
Joined: Tue Nov 29, 2016 2:45 pm

Re: FX Sound Board random skips in audio output

by jkandler on Thu Aug 29, 2019 1:11 pm

The powered speaker is an Amazon product. https://www.youtube.com/watch?v=s14H4hthSSM Not using the Bluetooth input for the speaker, using a 3' phone jack cord. The Casio speaker works great, but not as load is the Amazon speaker. The Amazon speaker appears to cause the sound board to skip (miss playing several seconds of audio) randomly. Not an issue with the Casio speaker or earbuds.

jkandler
 
Posts: 6
Joined: Tue Aug 20, 2019 2:34 pm

Re: FX Sound Board random skips in audio output

by adafruit_support_carter on Thu Aug 29, 2019 2:55 pm

That seems like it should have a pretty standard audio input jack. Maybe there is some internal damage to it? And it's causing a short or something which then glitches the playback? Not sure why that specific speaker would cause this issue.

adafruit_support_carter
 
Posts: 12991
Joined: Tue Nov 29, 2016 2:45 pm

Re: FX Sound Board random skips in audio output

by jkandler on Fri Aug 30, 2019 11:01 am

The Amazon BSK20 plays from my computer and other devices without skips. I have several around the house that I tried. In fact I am listening to Pandora on my computer playing through the audio jack on Amazon BSK20. Beautiful sound with no skips at all. With all of the testing I have done trying to make this combination work, I have concluded that the Sound Board does not properly function for the range of device input impedances of in the marketplace. I chased this for a long time. Purchased a new phone jack cable. Borrowed portable speakers from friends.

Food for thought. Just because you try a product many times in the lab it does not mean that it will always function in the broad marketplace, unless it is designed with broad operating margins from the start.

jkandler
 
Posts: 6
Joined: Tue Aug 20, 2019 2:34 pm

Re: FX Sound Board random skips in audio output

by adafruit2 on Mon Sep 02, 2019 12:51 am

the output is AC coupled, you can use any 16ohm+ impedence really...only thing i can think of is the bluetooth speakers are doing something 'clever' and they think the audio is off. the output from the sound board is just plain audio :/

adafruit2
Site Admin
 
Posts: 18664
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.