0

adafruit mp3 music maker shield not connecting to arduino un
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

adafruit mp3 music maker shield not connecting to arduino un

by jennaldb on Mon May 03, 2021 10:50 pm

I'm revisiting an old project that definitely used to work. I got it to work once, but now when I connect the music maker shield to my arduino, it just shuts off. :(

I've gone over the pins and tried to touch up the solder; it looks like they're all connected.

Is there anything else that could be wrong? I'll attach pictures as well.

Any help is greatly appreciated!

IMG_0177.JPG
IMG_0177.JPG (141.57 KiB) Viewed 148 times
IMG_0178.JPG
IMG_0178.JPG (161.46 KiB) Viewed 148 times

jennaldb
 
Posts: 2
Joined: Sat Mar 02, 2019 6:52 pm

Re: adafruit mp3 music maker shield not connecting to arduin

by blnkjns on Tue May 04, 2021 12:30 am

I see a couple of things:
There's a whole bunch of wires coming from the shield. Where do they go? If a board shuts off, it usually means there is a short between 0 and 5V somewhere, so the USB port in your computer decides to shut it off. Start with connecting just the music shield to see if the short is caused by the shield itself, or by the stuff connected to it.
The solder blobs are too big at times, they could cause shorts. Even if they didn't in the past, they might have collected dust and other particles. I would recommend cleaning them up a bit with a solder iron with fine tip and small solder wire (0.6mm). Use something like this to remove excessive solder:
https://www.adafruit.com/product/148

blnkjns
 
Posts: 610
Joined: Fri Oct 02, 2020 3:33 am

Please be positive and constructive with your questions and comments.