Due to high demand expect some shipping delays at this time, orders may not ship for 1-2 business days.
0

CC3000 no reply on ping
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: CC3000 no reply on ping

by sketchy on Tue Sep 17, 2013 4:22 pm

Thank you. I don't know if this is clear, but a couple of things I thought was weird:
1) My mac is and the same subnet as the cc3000. The cc3000 doesn't get results from the ping.
-> I agree, 0 sent looks VERY suspicious.
2) WebClient works - meaning the cc3000 finds www.adafruit.com, sends TCP packets and gets a response.

This strikes me as weird and then I don't understand how the routing can be incorrect if a TCP connection can be made but a ping can't be made? Note: I can ping from terminal to www.adafruit.com.....

One thing for sure, we peel an onion we find a whole 'nother bag of onions to peel - particularly when it comes to networking. But that is the fun of all of this. Frustration -> fixing -> learning...

sketchy
 
Posts: 261
Joined: Thu Jun 28, 2012 11:37 pm

Re: CC3000 no reply on ping

by berko on Thu Sep 19, 2013 3:48 pm

if i have an wireless access point that is not listed in TI's list of tested/approved APs what is the chance i will be able to connect?
it is a lynksys E1200.
don't want to buy a cc3000 shield at this point if it is not going to work.
how can i test this or verify it without purchasing one?
what would be different about my access point that would make it not work (i know, like a million things, right)?
thanks for any insight.

best,
jon

berko
 
Posts: 67
Joined: Sat Aug 04, 2012 6:44 pm

Re: CC3000 no reply on ping

by adafruit_support_rick on Thu Sep 19, 2013 4:59 pm

Honestly, I think the chances of it not working with your AP are very low. LinkSys routers are very mainstream.

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: CC3000 no reply on ping

by djix123 on Sat Nov 30, 2013 10:23 am

Just a quick update: it appears the CC3000 boards with firmware 1.24 have the issue fixed with IP addresses in the range 10.0.X.Y

djix123
 
Posts: 28
Joined: Mon Aug 26, 2013 7:58 pm

Re: CC3000 no reply on ping

by adafruit_support_mike on Sat Nov 30, 2013 4:21 pm

Good. It's nice to get confirmation of that from the field.

Thanks for posting!
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.

adafruit_support_mike
 
Posts: 63812
Joined: Thu Feb 11, 2010 2:51 pm

Re: CC3000 no reply on ping

by a19i23 on Wed Aug 13, 2014 9:35 pm

I have tried that example and it gets stuck.

Hello, CC3000!

Free RAM: 1215

Initializing...
Connected!
Request DHCP



IP Addr: 10.0.1.23
Netmask: 255.255.255.0
Gateway: 10.0.1.1
DHCPsrv: 10.0.1.1
DNSserv: 10.0.1.1
http://www.adafruit.com -> 207.58.139.247



...and it gets stuck there.

On the buildtest.ino I had to comment out the firmware check for it to work. It says it has version 1.10. Don't know if this is related.

a19i23
 
Posts: 5
Joined: Wed Aug 13, 2014 8:16 pm

Re: CC3000 no reply on ping

by adafruit_support_rick on Thu Aug 14, 2014 10:08 am

Firmware version 1.10? I don't think we ever shipped that. Did you get this module from Adafruit?

The older firmware versions did not work with 10.x.x.x networks. You should update your firmware. Use the driverpatch_1_12 sketch (driverpatch_1_13 is a beta version, and we don't recommend it).

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: CC3000 no reply on ping

by adafruit2 on Thu Aug 14, 2014 12:42 pm

adafruit_support_rick wrote:Firmware version 1.10? I don't think we ever shipped that. Did you get this module from Adafruit?

The older firmware versions did not work with 10.x.x.x networks. You should update your firmware. Use the driverpatch_1_12 sketch (driverpatch_1_13 is a beta version, and we don't recommend it).


if it doesnt pass the firmware test its unlikely its from adafruit - we update the firmware and test each module before shipping.

adafruit2
Site Admin
 
Posts: 20363
Joined: Fri Mar 11, 2005 7:36 pm

Re: CC3000 no reply on ping

by a19i23 on Thu Aug 14, 2014 1:51 pm

Yes it is from Adafruit.
Attachments
Screen Shot 2014-08-14 at 10.49.54 AM.png
Screen Shot 2014-08-14 at 10.49.54 AM.png (57.48 KiB) Viewed 455 times

a19i23
 
Posts: 5
Joined: Wed Aug 13, 2014 8:16 pm

Re: CC3000 no reply on ping

by adafruit_support_rick on Thu Aug 14, 2014 1:56 pm

Very strange that it would come like that. Can you try installing driverpatch_1_12 from the Adafruit_CC3000_Library?

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: CC3000 no reply on ping

by a19i23 on Thu Aug 14, 2014 2:19 pm

ok, i'll try

a19i23
 
Posts: 5
Joined: Wed Aug 13, 2014 8:16 pm

Please be positive and constructive with your questions and comments.