0

Adafruit Bluefruit LE Sniffer no lights -- not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Adafruit Bluefruit LE Sniffer no lights -- not working

by melbeckman on Tue Jan 12, 2016 8:09 pm

I recently bought the “ Adafruit Bluefruit LE Sniffer - Bluetooth Low Energy (BLE 4.0) - nRF51822 - v1.0 [ADA2269]” via Amazon (Order # 116-0452628-5662621). However, I am not able to get it to work.

I carefully followed the instructions, installed the FTDI driver on both Mac and Windows computers. But when I then plug the sniffer stick in, although both OSes create a new com port, I can’t get the unit to come alive.

I tried the terminal program checkout described in the instructions (using Putty on Windows 10, Zterm on Mac OS X Yosemite). The terminal emulator programs recognize the com ports and I can connect them at the speed 9600 8N1 with hardware flow control. But no lights come on, except that when I type keystrokes the TX light flashes briefly for each keystroke. Typing “AT” commands, such as ATI, fails to produce any output.

Nordic's nRF Sniffer Utility also doesn’t recognize the stick under Windows. Even replugging it, and rebooting, doesn’t help. I’ve tried all the direct USB ports on both Windows and Mac machines. I also installed the ble-sniffer-osx app on my Mac and it does not recognize a sniffer is even plugged in.

On the Mac, the appropriate /dev files are created and have correct ownership:

$ ls -l /dev/cu*
crw-rw-rw- 1 root wheel 18, 1 Jan 11 23:08 /dev/cu.Bluetooth-Incoming-Port
crw-rw-rw- 1 root wheel 18, 3 Jan 11 22:33 /dev/cu.Bluetooth-Modem
crw-rw-rw- 1 root wheel 18, 11 Jan 11 23:08 /dev/cu.usbserial-DN00FUXU
$ ls -l /dev/tty.usbserial*
crw-rw-rw- 1 root wheel 18, 10 Jan 11 23:08 /dev/tty.usbserial-DN00FUXU


Does the fact that I see no lights when I plug it in mean the unit is defective?

melbeckman
 
Posts: 7
Joined: Thu Dec 23, 2010 4:16 am

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by melbeckman on Tue Jan 12, 2016 8:22 pm

In addition, I installed the latest versions of the FTDI drivers (v2.3 for the MacYoemite, 2.12.10 ofr Windows 10).

melbeckman
 
Posts: 7
Joined: Thu Dec 23, 2010 4:16 am

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by adafruit2 on Wed Jan 13, 2016 1:42 pm

The lights are not usd for the sniffer. the sniffer firmware is written by nordic, it doesnt respond to AT commands - you have to use their tools.

please post a screenshot of what the windows software says when you try running the software
https://learn.adafruit.com/introducing- ... nrfsniffer

adafruit2
Site Admin
 
Posts: 17756
Joined: Fri Mar 11, 2005 7:36 pm

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by melbeckman on Wed Jan 13, 2016 7:57 pm

I am on a Mac at the moment and not able to run the PC program you requested. However, here is the output using the Python utility for the Mac, which is in your instructions:

melpro15:Adafruit_BLESniffer_Python-master admin$ sudo python sniffer.py /dev/tty.usbserial-DN00FUXU
Logging data to logs/capture.pcap
Connecting to sniffer on /dev/tty.usbserial-DN00FUXU
Scanning for BLE devices (5s) ...
Traceback (most recent call last):
File "sniffer.py", line 153, in <module>
devlist = scanForDevices()
File "sniffer.py", line 50, in scanForDevices
mySniffer.scan()
File "/Users/admin/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/Sniffer.py", line 62, in scan
self._startScanning()
File "/Users/admin/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/SnifferCollector.py", line 206, in _startScanning
self._packetReader.sendScan()
File "/Users/admin/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/Packet.py", line 185, in sendScan
self.sendPacket(REQ_SCAN_CONT, [], timeout)
File "/Users/admin/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/Packet.py", line 182, in sendPacket
self.uart.writeList(packetString, timeout)
File "/Users/admin/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/UART.py", line 73, in writeList
nBytes = self.ser.write(array)
File "build/bdist.macosx-10.11-intel/egg/serial/serialposix.py", line 517, in write
serial.serialutil.SerialException: Attempting to use a port that is not open

melbeckman
 
Posts: 7
Joined: Thu Dec 23, 2010 4:16 am

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by adafruit2 on Thu Jan 14, 2016 1:33 pm

OK - are you super sure you installed the latest FTDI drivers and restarted?

adafruit2
Site Admin
 
Posts: 17756
Joined: Fri Mar 11, 2005 7:36 pm

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by melbeckman on Thu Jan 14, 2016 2:05 pm

Super duper sure. There is only one version of the FTDI drivers on the FTDI site for Mac OS X Yosemite. It would be hard for me to get it wrong without trying super hard :)

Plus I repeated the whole process on another Mac, one running El Capitan. And don't forget that I tried Windows 10 too (although I don't have access to that machine righht now).

melbeckman
 
Posts: 7
Joined: Thu Dec 23, 2010 4:16 am

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by adafruit2 on Thu Jan 14, 2016 2:13 pm

its this error thats odd

Code: Select all | TOGGLE FULL SIZE
serial.serialutil.SerialException: Attempting to use a port that is not open


its not even opening the device...you dont have the serial port open anywhere else right? we can try replacing it - email support@adafruit and ask for a new one with a link to this thread. not sure that will help but worth a shot!

adafruit2
Site Admin
 
Posts: 17756
Joined: Fri Mar 11, 2005 7:36 pm

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by melbeckman on Thu Jan 14, 2016 3:03 pm

No, nothing else is using the serial port. I've tried running the python utility immediately after booting, and no other applications start automatically. I will request an RMA.

melbeckman
 
Posts: 7
Joined: Thu Dec 23, 2010 4:16 am

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by wmbest2 on Thu Mar 24, 2016 2:39 pm

Sorry to dig up an old thread but I am in the same boat. The device LED is blinking constantly. I was able to get it to work once and then from here on out I'm getting the following:

I am running Ubuntu 15.10

Code: Select all | TOGGLE FULL SIZE
Logging data to logs/capture.pcap
Connecting to sniffer on /ev/ttyUSB0
Scanning for BLE devices (5s) ...
Traceback (most recent call last):
  File "sniffer.py", line 153, in <module>
    devlist = scanForDevices()
  File "sniffer.py", line 50, in scanForDevices
    mySniffer.scan()
  File "/home/wmbest2/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/Sniffer.py", line 62, in scan
    self._startScanning()
  File "/home/wmbest2/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/SnifferCollector.py", line 206, in _startScanning
    self._packetReader.sendScan()
  File "/home/wmbest2/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/Packet.py", line 185, in sendScan
    self.sendPacket(REQ_SCAN_CONT, [], timeout)
  File "/home/wmbest2/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/Packet.py", line 182, in sendPacket
    self.uart.writeList(packetString, timeout)
  File "/home/wmbest2/Downloads/Adafruit_BLESniffer_Python-master/SnifferAPI/UART.py", line 73, in writeList
    nBytes = self.ser.write(array)
  File "/home/wmbest2/.local/lib/python2.7/site-packages/serial/serialposix.py", line 517, in write
    raise portNotOpenError
serial.serialutil.SerialException: Attempting to use a port that is not open

wmbest2
 
Posts: 1
Joined: Thu Mar 24, 2016 2:37 pm

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by paulfecht on Mon Feb 27, 2017 7:28 pm

I figured out a solution to the : "File "build/bdist.macosx-10.11-intel/egg/serial/serialposix.py", line 517, in write
serial.serialutil.SerialException: Attempting to use a port that is not open" -- Problem.

For me it was the fact that I had a Wireless USB adapter plugged into one of the ports. In particular the Edimax 5GHz wireless adapter for Macintosh.

Unplug that and use the BLE sniffer as described and all will work well. Happy sniffing.

paulfecht
 
Posts: 4
Joined: Mon Feb 27, 2017 7:25 pm

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by sseaburn on Fri Apr 14, 2017 10:22 pm

Just received Adafruit BLE Sniffer. Attempted operation on Mac and then on Windows 10(64bit) machine. Loaded the CP2104 VCP driver on both machines. On Mac, using Python sniffer.py got error message "serial.serialutil.SerialException: Attempting to use a port that is not open". Tried digging around in the python source without success. Switched to Windows machine.

Installed CP2104 VCP driver.(Dongle shows up as COM5 in Device Manager) Installed nRF-Sniffer from nordicsemi.com. Installed Wireshark verison 1.12.1 as per tutorial instructions. Rebooted.

When dongle is installed and switch set to CMD the red LED blinks fast three times pauses for about 3 seconds and repeats.
With switch set to DATA the red LED blinks twice pauses and repeats and yellow LED closest to SiLabs chip blinks once every 5 seconds.

Ran 'ble-sniffer_win_1.0.1_1111_Sniffer.exe as Administrator. Program does not find dongle. Unplug and retry as instructed. Same results with dongle switch set to CMD or DATA. Tried placing comPort=5 in sniffer.cfg file. Tried using comPort=COM5. Still unable to get sniffer app to see dongle. Am I missing something or do I just have a bad dongle? Thanks in advance.

sseaburn
 
Posts: 2
Joined: Fri Apr 14, 2017 9:28 pm

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by adafruit2 on Fri Apr 14, 2017 11:19 pm

ssea, i think you got a BLE friend not a BLE sniffer - please email support@adafruit and ask for a replacement!

adafruit2
Site Admin
 
Posts: 17756
Joined: Fri Mar 11, 2005 7:36 pm

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by sseaburn on Sat Apr 15, 2017 6:20 pm

adafruit2 - Thanks very much. I will do as you suggested. I suspected that the device might not be a sniffer as it works just like the BLE Friend.

sseaburn
 
Posts: 2
Joined: Fri Apr 14, 2017 9:28 pm

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by NadSo on Fri Jun 23, 2017 4:46 am

Hello,

I am working with the nRF51822 Bluefruit LE Friend v2 on Windows 7. Following the instructions of the user Guide I plug my device to my PC but the operating mode (command, data, DFU) don't work. I mean the LED don't light at all and I am not able to see the LE Friend when i launch the nRF UART v2.0 App on my Android phone. I also tried to use it as sniffer with the ble-sniffer_win_1.0.1_1111_sniffer.exe but I could not see any BLE device on my Terminal.


Thank for your help.

NadSo
 
Posts: 5
Joined: Fri Jun 23, 2017 4:34 am

Re: Adafruit Bluefruit LE Sniffer no lights -- not working

by adafruit2 on Fri Jun 23, 2017 11:18 am

the BLE Friend and LE sniffer are two different firmware. if you bought a Friend, it cannot be used as a Sniffer!

adafruit2
Site Admin
 
Posts: 17756
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.