0

Compiling and Flashing Blank ATTINY85
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Compiling and Flashing Blank ATTINY85

by dsmith00 on Sat Jul 01, 2017 8:05 pm

I have managed to finally get the firmware v1.2 to compile without any errors and flash it to a blank attiny85. I am having a major problem and hope someone can help. I am using Linux Mint 17.3, arduino uno which is setup to work with the attiny85 at 8MHz and avrdude. My goal is to add a few more N.A. TV codes and remove some European codes to make room....if possible.

Once compiled the new tvbgone.hex file is completely different than the original in the zip file (I have not modified any TV codes...I want to see if I can get the original to compile first.)

In order to compile without errors, I had to modify the makefile and a couple of lines in main.c, line 82 to: extern const PGM_P *const NApowerCodes[] PROGMEM;
and line 83 to: extern const PGM_P *const EUpowerCodes PROGMEM; --I also had to add const to a couple of lines in WORLDcodes.c. When I invoke make program the first thing that shows in the terminal is: avrdude -p attiny85 -P /dev/ttyACM0 -c arduino -b 19200 -v -v -B 1 -U flash:w:tvbgone.hex and it goes all the way through without any errors and flashes the chip. I do have a working tv-b-gone and when I swap chips it does not work. If I look at the IR emmiters through a camera they are on solid and the green led flashes a few times and stops.

Now if I flash the same chip with the original tvbgone.hex from the zip file like this: avrdude -c arduino -p t85 -b 19200 -P /dev/ttyACM0 -U flash:w:tvbgone.hex, it works perfectly!

Does anyone have any ideas on what might be going wrong?

P.S. I am not a programmer...and I type with two fingers :)

dsmith00
 
Posts: 2
Joined: Sat Jul 01, 2017 6:55 pm

Re: Compiling and Flashing Blank ATTINY85

by dsmith00 on Mon Jul 03, 2017 5:51 am

Ghan2011 wrote:That's easy, you need to try th


I have know idea what you are talking about...can you clarify?

dsmith00
 
Posts: 2
Joined: Sat Jul 01, 2017 6:55 pm

Re: Compiling and Flashing Blank ATTINY85

by kandizzy on Sun Feb 11, 2018 2:49 pm

Hello, I had similar issues after making the same changes to the code that you did (adding const to get it to compile) I made another forum post before I saw this one.


viewtopic.php?f=23&t=130881

kandizzy
 
Posts: 11
Joined: Wed Feb 19, 2014 4:28 pm

Please be positive and constructive with your questions and comments.