๐Ÿ“ฃ๐Ÿ“ช ๐Ÿšš Adafruit will not be shipping USPS orders Monday January 20, 2020 ๐Ÿ—“. Expedited USPS orders placed after 11am ET ๐Ÿ•š Friday January 17 will go out Tuesday January 21 ๐Ÿ“ฃ๐Ÿ“ช๐Ÿšš
0

Issue with TV-B-GONE fuses
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Issue with TV-B-GONE fuses

by saraiva on Wed May 02, 2018 12:31 pm

I built the this schematic https://raw.github.com/adafruit/TV-B-Go ... ne3sch.png in a protoboard
The only modifications is:
I am using Dispark ATtiny85:
I am using a 8MHZ crystal with 2 capacitors of 18pF

I could do the Upload of the tvbgone.hex and could see (with a cam) the IR leds blinking. But I couldn't turn off any TV.
So I checked the fuses: E:FE, H:DD, L:E1

I modified the fuses using: avrdude -b 19200 -P /dev/ttyACM0 -c avrisp -p t85 -U lfuse:w:0xfd:m -U hfuse:w:0xde:m
The avr did the modifications, and I could read the values of fuses.
But....
When I plugged the Digispark again in the circuit, the leds, didn't blink anymore.

I tried read the fuses values again (I am using Arduino Uno as a Programmer) and now It was not possible:

avrdude: Device signature = 0x000000
avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check.

What is wrong? Is my board dead?
Pleas help. I would like to use these project to arduino day next 12th

saraiva
 
Posts: 1
Joined: Wed May 02, 2018 12:01 pm

Please be positive and constructive with your questions and comments.