๐ŸŽ„โ›„โ„๏ธ๐ŸŽ It's beginning to look a lot like ADABOX-mas! The next ADABOX from Adafruit ships soon! Get yours now, or give as a gift! ๐ŸŽ„โ›„โ„๏ธ๐ŸŽ
0

green LED flashes 7 times, no output from IR
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

green LED flashes 7 times, no output from IR

by phinegan on Wed Jan 06, 2016 6:30 pm

After changing to a 3-cell battery pack, the green LED flashes 7 times and I can't see anything from the IR bulbs in my digital camera.
Any idea what's wrong?
Thanks!

phinegan
 
Posts: 3
Joined: Wed Jan 06, 2016 6:26 pm

Re: green LED flashes 7 times, no output from IR

by adafruit_support_rick on Fri Jan 08, 2016 12:20 pm

It used to work with a 2-cell pack? What happens if you switch back to 2 cells?

Please post some clear, detailed pictures of the TV-B-Gone.

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: green LED flashes 7 times, no output from IR

by phinegan on Fri Jan 08, 2016 6:56 pm

I get the same result with the two cell pack. What do the seven LED flashes indicate? I'm confident that my assembly of the kit is correct.
Thank you!

phinegan
 
Posts: 3
Joined: Wed Jan 06, 2016 6:26 pm

Re: green LED flashes 7 times, no output from IR

by phinegan on Fri Jan 08, 2016 7:20 pm

I stand corrected - it works fine with the two cell battery pack but not with the three cell. I'm measuring 5.5 volts from the three cell pack - could that be excessive for the device?

phinegan
 
Posts: 3
Joined: Wed Jan 06, 2016 6:26 pm

Re: green LED flashes 7 times, no output from IR

by adafruit_support_rick on Sat Jan 09, 2016 11:48 am

The TV-B-Gone runs on 3-5V. 5.5V might be a problem

The green LED is supposed to flash every time it sends out an IR code. But in this case, it sounds like an error condition - perhaps the processor is resetting?

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: green LED flashes 7 times, no output from IR

by Maze101 on Sat Jan 14, 2017 8:37 pm

I switched out the the AA battery pack for one of the 3.7V 2000 mAh Lipo's. I also included a bread board SPDT switch, a panel-ish mounted female JST for recharging, and a new taller tactile switch I replaced the original with (all stuffed in an Altoids tin).
I checked the battery voltage and its supplying 4.2V.
The green LED flashes 7 times when power is supplied and each time the tactile button is used. The device does not continue to blink like it did (For each code) when the AAs were attached.
Any idea if I fried the chip or if something else is going on?
I have not been able to determine what the 7 blinks stands for so trouble shooting is thusly limited.

Any input on what might be going on would be appreciated.

Maze101
 
Posts: 3
Joined: Sat Jan 14, 2017 4:51 pm

Re: green LED flashes 7 times, no output from IR

by adafruit_support_rick on Sun Jan 15, 2017 11:01 am

Hmmm... I don't see anything in the firmware that will flash the LED 7 times. Is it a fast blink or a slow blink?

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: green LED flashes 7 times, no output from IR

by Maze101 on Sun Jan 15, 2017 1:28 pm

It blinks approximately once every second, seven times, then stays off.
I checked the IRs with my phone and it does not appear to be firing any of them.

Update:
Was trying to avoid hacking the wiring apart, but C'est la vie....
Re-installed the 2 cell AA pack and ta-daa, worked again. Tried the Lipo directly to the board and mixed results at the moment... Likely I just don't have a secure connection for this particular test. I intend to rewire a few things later tonight, but at this time I suspect that the switch or charging port might have played a role...

Will update if I determine anything of worth. Maybe save someone else a head scratch moment...

Maze101
 
Posts: 3
Joined: Sat Jan 14, 2017 4:51 pm

Re: green LED flashes 7 times, no output from IR

by adafruit_support_rick on Sun Jan 15, 2017 2:57 pm

The firmware will slow blink like that on a brownout, but it will only blink twice.. You could be seeing a startup blink and then three brownouts.. I don't know.

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Please be positive and constructive with your questions and comments.