Adafruit Industries, Essential service and business: NYC – Executive Order 202.6 - Read more. Accepting essential orders - here's how.
0

Clue not booting up on battery
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Clue not booting up on battery

by gwerhart0800 on Sun Feb 23, 2020 2:58 pm

I implemented an iBeacon on the Clue, as I wanted to see how the nRF52840 performed relative to the version I did for the nRF51822 based Microbit. For my purposes, I use the A/B buttons to change the transmit power and I am playing with the range. The Clue board works fine on battery with the arcada_clue_test app loaded. However, when I load my beacon app (a modified version of the demo beacon app), it only boots up when plugged into a USB port on my Macbook Air. When I plug it in to the battery (3xAA) or use a USB cable to a li-ion battery, I can see the backlight for the screen come on, but nothing else. Since the clue test app does not fire up the radio, is there an issue powering the radio from battery?
Attachments
beacon.ino
(5.02 KiB) Downloaded 3 times

gwerhart0800
 
Posts: 4
Joined: Fri Dec 27, 2013 11:24 am

Re: Clue not booting up on battery

by adafruit_support_carter on Mon Feb 24, 2020 12:29 pm

Comment out this line:
Code: Select all | TOGGLE FULL SIZE
  while ( !Serial ) delay(10);   // for nrf52840 with native usb

adafruit_support_carter
 
Posts: 14974
Joined: Tue Nov 29, 2016 2:45 pm

Re: Clue not booting up on battery

by gwerhart0800 on Mon Feb 24, 2020 4:08 pm

Thanks! I did not see that it was getting stuck in an infinite loop!

gwerhart0800
 
Posts: 4
Joined: Fri Dec 27, 2013 11:24 am

Please be positive and constructive with your questions and comments.