Pygamer battery charge port - not charging

For Adafruit customers who seek help with microcontrollers

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
DMoultano33
 
Posts: 3
Joined: Sat Aug 06, 2022 9:35 pm

Pygamer battery charge port - not charging

Post by DMoultano33 »

Hello support -

I got my son a Pygamer a while back and we recently purchased a 350Mah Lipo battery for it. The problem is that the Pygamer doesn't seem to be charging. If I hook up a volt meter to the battery connector - I register no voltage. With it turned on there's no voltage, and with the battery plugged in - no voltage either. Oddly - I didn't get any voltage when measuring the battery itself (not a great sign for the battery). For second I thought maybe something was wrong with the volt meter, but a AA battery measured 1.62 volts, so that's not it.

Battery aside - should I be reading a voltage off the Pygamer's battery port while its turned off and plugged into USB? Is there something I need to enable on the board for the charging feature? Perhaps it needs to detect a voltage from the battery first in order to begin charging as sort of a safety measure?

I look forward to your reply.

User avatar
Franklin97355
 
Posts: 22863
Joined: Mon Apr 21, 2008 2:33 pm

Re: Pygamer battery charge port - not charging

Post by Franklin97355 »

It should, can you post a picture of it while plugged in? Also, does it work when plugged into the USB?

User avatar
DMoultano33
 
Posts: 3
Joined: Sat Aug 06, 2022 9:35 pm

Re: Pygamer battery charge port - not charging

Post by DMoultano33 »

Franklin, thanks for the reply. I'm on a trip right now, so I can't take a pic. The Pygamer works fine while plugged into USB. I think I saw in the forums that a yellow light should come, or some sort of charge light. I don't see this happening.

User avatar
DMoultano33
 
Posts: 3
Joined: Sat Aug 06, 2022 9:35 pm

Re: Pygamer battery charge port - not charging

Post by DMoultano33 »

Are you still waiting for me to send a pic of it not charging? Is there something else I can try? Can anyone just tell me if there's some sort of low voltage protection in play here?

User avatar
Franklin97355
 
Posts: 22863
Joined: Mon Apr 21, 2008 2:33 pm

Re: Pygamer battery charge port - not charging

Post by Franklin97355 »

Did you get the battery from Adafruit? If not a picture of it hooked up would help and if you could test the battery for voltage and polarity it would also help.

Post Reply
Please be positive and constructive with your questions and comments.

Return to “Microcontrollers”