0

Pro Trinket not uploading
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Pro Trinket not uploading

by OhBaby on Sun Nov 11, 2018 12:59 pm

Pro Trinket error Capture.JPG
screen capture of error messages
Pro Trinket error Capture.JPG (140.12 KiB) Viewed 161 times


Just connected a Pro Trinket for the first time and cannot seem to get it recognized by the IDE or upload any sketch.

Getting the sound from the PC indicating a device is connected but no COM port is added to the Serial port list.

I've downloaded the Windows drivers but don;t see any change to the Board options so I have tried several different after not getting the Arduino UNO board to work.

Any suggestions would be appreciated.

OhBaby
 
Posts: 19
Joined: Thu Apr 05, 2018 10:12 pm

Re: Pro Trinket not uploading

by franklin97355 on Sun Nov 11, 2018 9:00 pm

You should also install the Adafruit board files following the tutorial on Adding Third-Party Boards If you set the preferences to verbose for the compile and upload options you will get more information and can post that here.

franklin97355
 
Posts: 21087
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Pro Trinket not uploading

by OhBaby on Sun Nov 11, 2018 10:28 pm

Thank you.

I was able to download the Adafruit boards successfully.

Unfortunately the Pro Trinket 3V is not being recognized as a COM port still.

The PC gives a recognition sound but the only port that shows is COM1 whether the Pro Trinket is plugged in or not. I tried the USB and the FTDI version of the Pro Trinket 3V board to no avail.

Don;t know it it means anything or not but the red LED on the Pro Trinket changes from two quick blinks followed by a pause when on LiPo power to a long slow heart beat like flash cycle when on USB power.

OhBaby
 
Posts: 19
Joined: Thu Apr 05, 2018 10:12 pm

Re: Pro Trinket not uploading

by OhBaby on Sun Nov 11, 2018 10:53 pm

The below is the error message I keep getting.

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x03
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

OhBaby
 
Posts: 19
Joined: Thu Apr 05, 2018 10:12 pm

Re: Pro Trinket not uploading

by OhBaby on Sun Nov 11, 2018 11:00 pm

I do not see the L LED flash when resetting the board. What else might indicate there is no bootloader installed? Can I burn a bootloader onto this chip from the IDE?

"Bootloader

Make sure there's a bootloader burned on your Arduino board. To check, reset the board. The built-in L LED (which is connected to pin 13) should blink. If it doesn't, there may not be a bootloader on your board."

OhBaby
 
Posts: 19
Joined: Thu Apr 05, 2018 10:12 pm

Re: Pro Trinket not uploading

by franklin97355 on Sun Nov 11, 2018 11:05 pm

The Pro Trinket does not show up as a com port. Have you read through the tutorial on using the Pro Trinket and how to start the USB Bootloader?

franklin97355
 
Posts: 21087
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Pro Trinket not uploading

by OhBaby on Sun Nov 11, 2018 11:12 pm

OK looks like a work around may have been stumbled upon. :-)

Changing to the USBtiny ISP programmer and resetting just moments before uploading seems to have corrected the problem.

OhBaby
 
Posts: 19
Joined: Thu Apr 05, 2018 10:12 pm

Please be positive and constructive with your questions and comments.